在线检测未来函数

通达信改良MACD指标公式

来源:Internet,编辑:股旁网,2012-08-21

LC:=REF(C,1);
预量:=IF(ISLASTBAR,V*240/FROMOPEN,V),NODRAW;
量比:=预量/MA(REF(V,1),5),NODRAW;
JJ:=(L+H+C*2)/4;
DI:(EMA(C,12)-EMA(C,26))/C*500,COLORFF00FF;
DE:EMA(DI,9),LINETHICK1,COLORFFFFFF;
STICKLINE(DI>REF(DI,1) AND DI>DE AND MA(C,20)>REF(MA(C,20),1),-15,15,1,0),COLOR000066;
MACD:(DI-DE)*2,COLORSTICK,COLORFFAA00;
金:IF(((MACD<=-50 OR (MACD<=-30 AND MA(C,11)>REF(MA(C,11),1) AND MA(C,20)>REF(MA(C,20),1)
AND MA(C,60)>REF(MA(C,60),1)) AND (H>LC OR C<LLV(LC,6)*0.98) AND C=LLV(C,10) AND (L=LLV(L,15)
OR C<LLV(L,15)*1.015))) AND 预量<REF(V,1) AND 预量<MA(V,5) AND H<LLV(REF(L,1),2)*
1.06 AND C>LC*0.9014 AND H>LC AND C<L*1.025,48,0),LINETHICK2,COLOR00FFFF;
银:IF(LLV(MACD,8)<-40 AND (C=LLV(C,11) OR L=LLV(L,11)) AND
DOWNNDAY(C,2) AND NDAY(O,C,2) AND 预量<REF(V,1) AND 预量<MA(V,5) AND C>LC*0.9015
AND H<REF(H,1) AND H<LLV(REF(L,1),2)*1.06 AND C<L*1.02,45,0),LINETHICK4,COLORFFFFFF,STICK;
低:IF(MACD<-26 AND HHV(DE,10)-DE>25 AND HHV(DI,250)<10 AND ((C=LLV(C,11) AND (L=LLV(L,15) OR C<LLV
(L,15)*1.015)) OR (L<MA(C,5)*0.9 AND MA(C,5)/C>1.05)) AND H>LC AND C<MA(C,5)*0.96
AND H>LC AND C<L*1.025 AND H<LLV(REF(L,1),2)*1.06 AND C>LC*0.9014 AND
预量<REF(V,1),38,0),LINETHICK2,COLOR0099FF;
买:IF((LLV(DI,5)<-50) AND C<LLV(REF(L,1),10) AND H<LLV(REF(L,1),2)*1.06 AND C<L*
1.015 AND C>LC*0.9014 AND PERIOD=5 AND 预量<HHV(V,10),32,0),LINETHICK2,COLORFF00FF;
{www.gupang.com 股旁网_通达信股票指标公式}
抢:IF(LLV(MACD,10)<-16.2 AND HHV(DI,250)<10 AND C<MA(C,10)*0.92 AND L<MA(C,5)*0.88 AND
C<MA(C,5)*0.947 AND H>LC AND C=LLV(C,10) AND (L=LLV(L,10) OR C<LLV(L,10)*1.015) AND C<L*1.01 AND V<HHV
(V,10) AND C>LC*0.901 AND H<LLV(REF(L,1),2)*1.06 AND H>LC AND C<L*1.025,30,0),
LINETHICK2,COLORFF99FF;
低2:IF(((MACD<-35 AND C<LLV(REF(L,1),10) AND C<L*1.02 AND H<LLV(REF(L,1),2)*1.06) OR
((LLV(MACD,10)<-20 OR LLV(DE,10)<-30) AND C>400)) AND C=LLV(C,10) AND L=LLV(L,10),
15,0),LINETHICK3,STICK,COLORFFAA00;
买2:IF((HHV(REF(金,1),12)=10 AND C=LLV(C,10) AND (L=LLV(L,15) OR C<LLV(L,15)*1.015) AND
H>LC AND C>LC*0.9014) AND C*1.025>H AND H>LC AND C<L*1.025 AND H<LLV(REF(L,1),2)
*1.06,-MACD,0),LINETHICK2,COLORCC00FF;
高:IF(MACD>35 AND MACD>REF(MACD,1) AND C<LC*1.0985,-5,DRAWNULL),LINETHICK6,CROSSDOT,COLOR00FF00;
卖:IF(HHV(MACD,4)>=42 AND (C=HHV(C,10) AND ((H=HHV(H,10) OR H>LC*1.07) OR C<MA(C,20)))
AND (L<LC OR C>MA(C,5)*1.15) AND C<LC*1.0985,-10,0),STICK,LINETHICK3,COLOR00CC00;
危:IF(HHV(MACD,7)>42 AND C=HHV(C,10) AND H=HHV(H,10) AND C<LC*1.0985 AND PERIOD=5,-10,0),LINETHICK3,STICK,COLORFFFFFF;
大盘危:IF(HHV(MACD,8)>15 AND C>400 AND C<LC*1.0985 AND C=HHV(C,10) AND H=HHV(H,10),-15,
0),COLORFFFFFF,LINETHICK4,STICK;
DRAWICON(LLV(MACD,5)<-30 AND C>LC*0.9014 AND C<=O AND C=LLV(C,10) AND L=LLV
(L,10),MACD,9);
DRAWTEXT_FIX(ISLASTBAR AND DI>REF(DI,1) AND DI>DE AND C>MA(C,20),0.97,0.05,1,'上涨持股'),COLORYELLOW;

通达信改良MACD指标公式

 

相关文章