在线检测未来函数

通达信戒恐戒贪指标公式

来源:Internet,编辑:股旁网,2013-02-03

{多空乖离}
RSV1:=(C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
PJ1:=EMA(J1,7);
PJ2:=REF(PJ1,1);
JP1:=REF(INDEXC,1);
JP2:=FILTER((INDEXC-JP1)/JP1>0.01 AND (INDEXC-JP1)/JP1<0.05 AND PJ1>PJ2,5);
STICKLINE(JP2,K1,15,2.7,0),COLOR00FFFF;
DRAWTEXT(JP2,K1,'追'),COLOR0000FF;
DF:=4;
N1:=16;
RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;
K:=SMA(RSV,DF,1);
D:=SMA(K,DF,1);
KK:=SMA(RSV,DF,1);
DD:=SMA(K,DF,1);
N:=KK+DD;
GWGD:=N<REF(N,1) AND REF(N,1)>=165 AND REF(N,1)>=REF(N,2);
ADF:=8;
AN1:=24;
ARSV:=(CLOSE-LLV(LOW,AN1))/(HHV(HIGH,AN1)-LLV(LOW,AN1))*100;
AK:=SMA(ARSV,ADF,1);
AD:=SMA(AK,ADF,1);
AKK:=SMA(ARSV,ADF,1);
ADD:=SMA(AK,ADF,1);
AN:=AKK+ADD;
AGWGD:=AN<REF(AN,1) AND REF(AN,1)>=165 AND REF(AN,1)>=REF(AN,2);
戒恐区:=30,COLORYELLOW,LINETHICK2;
戒贪区:165,COLOR007700,LINETHICK2;
DRAWTEXT(ISLASTBAR,戒恐区*1,'戒恐'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,戒贪区*1,'戒贪'),COLORYELLOW;
NN:=27;M1:=9;M2:=9;P:=27;
XRSV:=(CLOSE-LLV(LOW,NN))/(HHV(HIGH,NN)-LLV(LOW,NN))*100;
XK:=SMA(XRSV,M1,1),COLORRED,LINETHICK2;
XD:=SMA(XK,M2,1),COLOR00FF00;
JJ:=P*(3*XD-2*XK),COLOR00FF00;
J:=((3 * XK) - (2 * XD));
MAIRU:= CROSS(XK,XD) AND XK<20;
MAICHU:= CROSS(XD,XK) AND XD>80;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,60);
VAR6:=HHV(VAR4,600);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
吸筹:STICKLINE(VAR9>-120,2,VAR9,2,1),COLORCCFF00;
A1:=REF(C,3);
A2:=SMA(MAX(C-A1,0),5,1)/SMA(ABS(C-A1),5,1)*1000;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
A4:=A2-LLV(A2,10);
A5:=(MA(A4,2)*3+A4*13)/16;
A6:=IF(A5>13,MA(A5,2),A5)/6;
RSI1:=SMA(MAX(C-A1,0),6,1)/SMA(ABS(C-A1),6,1)*100;
RSI2:=SMA(MAX(C-A1,0),12,1)/SMA(ABS(C-A1),12,1)*100;
RSI3:=SMA(MAX(C-A1,0),24,1)/SMA(ABS(C-A1),24,1)*100;
压力:=HHV(MA(RSI2,3),12);
支撑:=LLV(MA(RSI2,3),12);
中间:=(HHV(MA(RSI2,3),12)+LLV(MA(RSI2,3),12))/2,COLORRED,LINETHICK2;
短线:IF(CROSS(A6,1) AND (A6<30)AND RSI2<30 AND RSI2>=支撑 AND RSI2<中间,30,25),COLORMAGENTA;
{www.gupang.com 股旁网_通达信股票指标公式}
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWTEXT(B3,RSI2,'底背');
B1:=RSI1>=RSI2 AND RSI2>=RSI3;
S1:=RSI1<RSI2 AND RSI2<RSI3;
BS1:=NOT(RSI1>=RSI2 AND RSI2>=RSI3)AND NOT(RSI1<RSI2 AND RSI2<RSI3);
STICKLINE(B1,25,30,2,1)COLORRED;
STICKLINE(S1,25,30,2,1)COLORGREEN;
STICKLINE(BS1,25,30,2,1)COLORYELLOW;
STICKLINE(N>160,160,165,10,0),COLORBLUE;
关注区1:STICKLINE(N<35,N,30,2,0),COLORYELLOW;
风险区1:STICKLINE(N>165,N,165,10,0),COLORYELLOW;
关注区2:STICKLINE(AN<35,AN,30,2,0),COLORWHITE;
风险区2:STICKLINE(AN>165,AN,165,2,0),COLORWHITE;
乖离1:N,COLORFF00FF,LINETHICK1;
乖离2:AN,COLORRED,LINETHICK1;

通达信戒恐戒贪指标公式

 

相关文章