在线检测未来函数

通达信夏季主图指标公式

来源:Internet,编辑:股旁网,2013-05-12

M:=20;
M1:=7;
M2:=30;
M3:=60;
N:=14;
MA1:MA(CLOSE,M1),COLORCCCCCC,LINETHICK1;
MA2:MA(CLOSE,M2),COLORFF6600,LINETHICK1;
MA3:MA(CLOSE,M3),COLOR888800,LINETHICK1;
MA4:=MA(CLOSE,60),COLOR333333,LINETHICK1;
{------------------}
MID:=MA(C,M)COLOR999999,DOTLINE;
VART1:=POW((C-MID),2);
VART2:=MA(VART1,M);
VART3:=SQRT(VART2);
UPPER:=MID+2*VART3;
LOWER:=MID-2*VART3;
BOLL:=REF(MID,1);
UB:REF(UPPER,1),COLOR333333,LINETHICK2;
LB:REF(LOWER,1),COLOR333333,LINETHICK2;
AA:=V>MA(V,5);
BB:=V<MA(V,5);
CC:=MA2>REF(MA2,1),LINETHICK0;
IF(CC,MID,DRAWNULL),COLORLIBLUE,DOTLINE; {虚线}
IF(AA,UB,DRAWNULL),COLOR777700,LINETHICK1;
IF(BB,LB,DRAWNULL),COLORAAAAAA,LINETHICK1;
{---------------------}
STICKLINE(C>=O,H,C,0,0),COLOR333333;
STICKLINE(C>=O,H,C,0,0),COLOR444444;
STICKLINE(C>=O,O,L,0,0),COLOR555555;
STICKLINE(C>=O,O,L,0,0),COLOR666666;
STICKLINE(C>O,C,O,3.4,0),COLOR777777;
STICKLINE(C>O,C,O,3.0,0),COLOR888888;
STICKLINE(C>O,C,O,2.4,0),COLOR999999;
STICKLINE(C>O,C,O,2.0,0),COLORAAAAAA;
STICKLINE(C>O,C,O,1.6,0),COLORBBBBBB;
STICKLINE(C>O,C,O,1.2,0),COLORCCCCCC;
STICKLINE(C>O,C,O,0.6,0),COLORDDDDDD;
STICKLINE(C>O,C,O,0.1,0),COLOREEEEEE;
STICKLINE(C<=O,H,C,0,0),COLOR888800;
STICKLINE(C<=O,H,C,0,0),COLORFFFF00;
STICKLINE(C<=O,O,L,0,0),COLOR888800;
STICKLINE(C<=O,O,L,0,0),COLORFFFF00;
STICKLINE(C<=O,C,O,3.4,0),COLOR888800;
STICKLINE(C<=O,C,O,3.0,0),COLOR999900;
STICKLINE(C<=O,C,O,2.4,0),COLORAAAA00;
STICKLINE(C<=O,C,O,2.0,0),COLORBBBB00;
STICKLINE(C<=O,C,O,1.6,0),COLORCCCC00;
STICKLINE(C<=O,C,O,1.2,0),COLORDDDD00;
STICKLINE(C<=O,C,O,0.6,0),COLOREEEE00;
STICKLINE(C<=O,C,O,0.1,0),COLORFFFF00;
STICKLINE((ISLASTBAR,CROSS(CLOSE,MID) AND C>O),CLOSE,OPEN,0.1,0)COLORWHITE; {上穿中轨}
STICKLINE(OPEN>=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLORFF6600;
STICKLINE(OPEN>=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLORFF8800;
STICKLINE(OPEN>=CLOSE AND CLOSE<=MID,CLOSE,OPEN,1,0),COLORFFAA00;
STICKLINE(OPEN>=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0.6,0),COLORFFCC00;
STICKLINE(OPEN>CLOSE AND CLOSE<=MID,CLOSE,OPEN,3.3,0),COLORFF6600;
STICKLINE(OPEN>CLOSE AND CLOSE<=MID,CLOSE,OPEN,2.4,0),COLORFF8800;
STICKLINE(OPEN>CLOSE AND CLOSE<=MID,CLOSE,OPEN,1.3,0),COLORFFAA00;
STICKLINE(OPEN>CLOSE AND CLOSE<=MID,CLOSE,OPEN,0.6,0),COLORFFCC00;
{---------------------}
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLOR222222;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLOR333333;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,1,0),COLOR444444;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,3.4,0),COLOR555555;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,3.0,0),COLOR666666;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,2.4,0),COLOR888888;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,2.0,0),COLOR999999;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,1.6,0),COLORAAAAAA;
STICKLINE(OPEN<=CLOSE AND CLOSE<=MID,CLOSE,OPEN,0.1,0),COLORBBBBBB;
{-----------------------}
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLOR222222;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,0,0),COLOR333333;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,1.0,0),COLOR444444;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,3.4,0),COLOR666666;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,3.0,0),COLOR777777;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,2.4,0),COLOR888888;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,2.0,0),COLOR999999;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,1.6,0),COLORAAAAAA;
STICKLINE(OPEN<CLOSE AND CLOSE<=MID,CLOSE,OPEN,0.1,0),COLORBBBBBB;
{----买卖提示----}
ABC:=(REF(CLOSE,2)/REF(OPEN,2) < 1 AND
REF(OPEN,1) < REF(CLOSE,2) AND
ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)) OR
CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)); {波段买入点}
STICKLINE((ISLASTBAR,ABC),O,(O+C)/2,0,0),COLOR3299CC;
STICKLINE((ISLASTBAR,ABC),O,(O+C)/2,0,0),COLOR2F4F4F;
STICKLINE((ISLASTBAR,ABC),O,(O+C)/2,0.1,0),COLOR70DBDB;
STICKLINE((ISLASTBAR,ABC),O,(O+C)/2,0,0),COLOR38B0DE;
STICKLINE((ISLASTBAR,ABC),O,(O+C)/2,0,0),COLOR5F9F9F;
{DRAWICON(FILTER(CROSS((0 -19),-"WR.WR1"(14,14)),10),H,12); {图标}
DRAWICON(FILTER(CROSS(-"WR.WR1"(14,14),(0 - 81)),10),L-0.2,11); {图标}
{--向左画收盘线--}
C0:STICKLINE(CURRBARSCOUNT=1,C,C,10000,1),COLOR333333,LINETHICK1; {OR MINUTE=1}
{---小周期-------}
时间:=TIME=100000;
NT:=BARSLAST(时间);
常数:=CONST(IF(NT=0,C,REF(C,NT)));
CS1:=MA(L,1){*VAR0},NODRAW;
CS2:=CONST(IF(NT,LLV(L,0),REF(LLV(L,0),NT)));
STICKLINE(时间=1,CS1,CS2,-1,-1),COLOR333333; {小周期画影柱 适三十分钟分析};
{}
N1:=MINUTE;
JJ:=SUM(V*C,0)/SUM(V,0); {均价}
IF(N1,JJ,DRAWNULL),COLORYELLOW;
{}
D:=DYNAINFO(11)+(DYNAINFO(11)*0.021);
ZT:=IF(DYNAINFO(7)>D,1,0);
Z:=IF(ZT=1,C+0.0075,DRAWNULL),NODRAW;
DRAWBAND(Z,RGB(255,211,0),C-0.0075,RGB(255,125,0));
{-----------------------------}
NN:=100;
高点:=CONST(HHV(H,NN));
低点:=CONST(LLV(L,NN));
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
明日阻力2:=L+2*(GJ-L)+(C-L);
明日支撑2:=L+(C-GJ)-(GJ-L);
明日突破:=GJ+(H-L);
明日反转:=GJ-(H-L);
今日阻力:=CONST(REF(明日阻力 , 1)),NODRAW;
今日支撑:=CONST(REF(明日支撑 , 1)),NODRAW;
今日阻力2:=CONST(REF(明日阻力2 , 1)),NODRAW;
今日支撑2:=CONST(REF(明日支撑2 , 1)),NODRAW;
STICKLINE(ISLASTBAR,今日阻力,今日阻力2,1,0),COLOR008888; {0或1均可}
STICKLINE(ISLASTBAR,今日支撑,今日支撑2,1,0),COLOR008888; {0或1均可}
DRAWTEXT(CURRBARSCOUNT=2,今日阻力+0.15,'今 阻 区'),COLOR00009C,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=2,今日支撑-0.15,'今 支 区'),COLOR005500,LINETHICK2;
{----------------}
HHH:=CONST(HHV(H,100));
LLL:=CONST(LLV(L,100));
HH:=HHH-LLL;
TJ2:= CURRBARSCOUNT=58;
总家数:INDEXADV+INDEXDEC,NODRAW;
涨家数:INDEXADV,NODRAW;
跌家数:INDEXDEC,NODRAW;
差数:INDEXADV-INDEXDEC,NODRAW;
半分位:=(O+C)/2;
昨半价:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半价,昨半价,50,-1),COLOR2F2F4F,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,昨半价,' 昨'),COLOR2F2F4F,LINETHICK2;
底:=SUM(MA(CLOSE,10),9)/11.114;
VARA:=PEAKBARS(3,10,1)<10;
VARB:=IF(VARA=1,2,0);
顶:= IF(VARB=2,2,0);
DRAWICON(顶>REF(顶,1),H*1.005,2);
{DRAWICON(CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1)),L,1); }
DRAWICON(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),H,12);
DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'00',0);
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLOR005100;
支撑:=L1+P1*0.5/8,COLOR000075;
STICKLINE(ISLASTBAR,阻力,阻力,200,-1),COLOR00009C,,LINETHICK1;
STICKLINE(ISLASTBAR,支撑,支撑,200,-1),COLOR005500,,LINETHICK1;
DRAWTEXT(CURRBARSCOUNT=20,阻力,'阻'),COLOR00009C,LINETHICK1;
DRAWTEXT(CURRBARSCOUNT=20,支撑,'支'),COLOR005500,LINETHICK1;
{-----------------------}
D今日支撑:=STRCAT('今日支撑: ',CON2STR(今日支撑,2));
D今日阻力:=STRCAT('今日阻力: ',CON2STR(今日阻力,2));
D明日支撑:=STRCAT('明日支撑: ',CON2STR(明日支撑,2));
D明日阻力:=STRCAT('明日阻力: ',CON2STR(明日阻力,2));
D明日突破:=STRCAT('明日突破: ',CON2STR(明日突破,2));
D明日反转:=STRCAT('明日反转: ',CON2STR(明日反转,2));
{DRAWTEXT_FIX(ISLASTBAR,0.00,0.01,0,D今日支撑),COLOR00FFFF; {书文字}
{DRAWTEXT_FIX(ISLASTBAR,0.00,0.08,0,D今日阻力),COLOR00FF00;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.15,0,D明日支撑),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.22,0,D明日阻力),COLORFFFF00;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.29,0,D明日突破),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.36,0,D明日反转),COLORGREEN;}
{-----------------------}
VAR0:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR1:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR2:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR3:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR4:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR5:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR6:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR7:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR8:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
买1:=VAR0;
买2:=(VAR1+VAR3+VAR5+VAR7);
卖1:=(VAR2+VAR4+VAR6+VAR8);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

通达信夏季主图指标公式

 

相关文章