在线检测未来函数

大智慧春种秋实指标公式

来源:Internet,编辑:股旁网,2013-05-25

v1:=(C*2+H+L+o)/5; {均价}
V2:=EMA(V1,13)-EMA(V1,34);{macd.diff}
V3:=EMA(V2,5); {macd.dea}
V4:=(V2-V3)*100; {macd.macd}
主力撤:=IF(V4<=0,V4,0){,colorblue个股};
主力进:=IF(V4>=0,V4,0){,colorff00ff个股};
V8:=(INDEXC*2+INDEXH+INDEXL+indexo)/5;{大盘均价}
V9:=EMA(V8,13)-EMA(V8,34); {index.diff}
VA:=EMA(V9,5); {index.dea}
VB:=(V9-VA)/2; {index.macd}
V11:=3*SMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1)-2*SMA(SMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1),3,1);{引用个股"kdj.j"}
V12:=3*SMA((C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1)-2*SMA(SMA((C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1),3,1);{引用个股"kdj.j"}
V13:=3*SMA((C-LLV(L,120))/(HHV(H,120)-LLV(L,120))*100,5,1)-2*SMA(SMA((C-LLV(L,120))/(HHV(H,120)-LLV(L,120))*100,5,1),3,1);{引用个股"kdj.j"}
阳光:EMA(V11,3),coloryellow,linethick2;
空气:ema(v12,3),colorDD00FF;
雨露:EMA(V13,3),COLORblue;
dv11:=3*SMA((indexC-LLV(indexL,60))/(HHV(indexH,60)-LLV(indexL,60))*100,5,1)-2*SMA(SMA((indexC-LLV(indexL,60))/(HHV(indexH,60)-LLV(indexL,60))*100,5,1),3,1);
自然环境:ema(dv11,13),colorcyan,linethick2;
稻草人:空气<=10,linethick0,coloreecc99;
STICKLINE(空气<=10,0,15,5,0),coloreecc99;
麦田:空气<=10 AND (阳光<=10 or 自然环境<=10),linethick0,color00eeaa;
STICKLINE(空气<=10 AND (阳光<=10 or 自然环境<=10),0,20,4,0),COLOR00eeaa;
早熟:空气<=10 AND (阳光<=10 or 自然环境<=10) AND 雨露<=10,LINETHICK0,COLORMAGENTA;
STICKLINE(空气<=10 AND (阳光<=10 or 自然环境<=10) AND 雨露<=10,0,25,3,0),COLORMAGENTA;
光合作用:阳光<=10 and 空气<=10 AND 自然环境<=10 AND 雨露<=10,linethick0,colorred;
stickline(阳光<=10 and 空气<=10 AND 自然环境<=10 AND 雨露<=10,0,30,2,0),colorred;
aa:=filter((空气<=10),15);
XX:=filter(空气<=10 AND 自然环境<=10,15);
{drawtext (aa,30,'稻草人'),colorcc9900;
drawtext (xx,40,'麦田'),color00aaaa; }
bb:= (空气<=10 AND V12>10) and filter((空气<=10 AND V12>10),10);
乌鸦:空气>=90 and 空气>ref(空气,1),colorffff00,linethick0;
STICKLINE(乌鸦,100,95,15,1),COLORFFFF00;
暴风雨:空气>=90 AND 自然环境>=90,colorgreen,linethick0;
STICKLINE(暴风雨,100,95,10,0),COLORgreen;
收割:filter(空气>90 and 空气<ref(空气,1) and 主力进<ref(主力进,1),8);
DRAWTEXT( 收割,90,'收割'),coloryellow;
partline(阳光<=10,阳光),colorred,LINETHICK3;partline(阳光>=90,阳光),colorgreen,LINETHICK3;
STICKLINE(自然环境<=10,100,95,10,0),COLORred;
drawtext(filter(自然环境<=10,8),90,'农耕?'),colorred;

大智慧春种秋实指标公式

 

相关文章