在线检测未来函数

大智慧好使MACD指标公式

来源:Internet,编辑:股旁网,2013-12-20

DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,colorwhite,LINETHICK1;
DEA:EMA(DIFF,9),coloryellow,LINETHICK2;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:2*(DIFF-DEA),colorred,linethick0;
MACD2:wma(MACD1,3),colorcyan,linethick0;
STICKLINE(MACD1>MACD2 and macd1>0,0,MACD1,2,0),colorred;
STICKLINE(MACD1>MACD2 and macd1<0,0,MACD1,2,0),coloryellow;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),colorcyan;
s1:=MACD<0;
s2:= (MACD>=0);
s3:=BARSLAST(cross(diff,dea));
s4:=ref(s3,s3+1);
s5:=dea>ref(dea,s4);
s6:=dea;
上成立:=cross(diff,dea) and s5;
下成立:=cross(diff,dea) and s6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(cross(L1,L2));
L4:=ref(L3,L3+1);
L5:=L2;
变盘:cross(L1,L2) and L5,LINETHICK0,ColorD6FF9C;
STICKLINE(变盘,5,-5,4,1),linethick3,ColorD6FF9C;
成立距今:BARSLAST(cross(diff,dea)),LINETHICK0;
L6:=BARSCOUNT(CLOSE);
DRAWICON(CROSS(L1,L2),DIFF,7),ALIGN2,LAYER0;
DRAWICON(CROSS(L2,L1),DIFF,8),ALIGN2,LAYER0;
ref(dea,s3),POINTDOT,COLORGREEN;
IF(L1>L2,ref(dea,s3),0),POINTDOT,linethick5,ColorB078FF;
IF(MACD<0,ref(dea,s3),0),POINTDOT,linethick5,COLORGREEN;
VERTLINE(上成立,3),linethick3,Coloryellow;
VERTLINE(下成立,3),linethick3,Colorred;
PARTLINE(DIFF,DIFF>DEA),COLORff11cc,LINETHICK1;
PARTLINE(DIFF,DIFF>DEA AND DIFF<0),COLORred,LINETHICK1;
ls:=if(DIFF>DEA AND DIFF>0,1,0);
加速上扬:if(ref(ls=0,1) AND ls=1,0.1,0);
xg1:cross(MACD1,MACD2) and macd1<0,linethick0;
xg2:cross(diff,dea),linethick0;
m1:=macd>ref(macd,1) and diff<dea;
绿柱短了:m1 and count(m1,10)=1 and c>ma(c,55) and count(macd<0,5)>=5,linethick0;
drawtext(绿柱短了,macd,'绿柱短了');
DRAWGBK((CLOSE > 0),STRIP(RGB(4,1,28),RGB(4,1,35),0));

大智慧好使MACD指标公式

 

相关文章