在线检测未来函数

通达信胜庄之宝指标公式

来源:Internet,编辑:股旁网,2014-04-28

趋势线:(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(95),5,1),3,1)),CoLorF0F000;
买点准备:IF((趋势线<=10),12,0),Linethick2,CoLor0000FF;
V1:=MA(((100)*(CLOSE-LLV(CLOSE,34)))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
V2:=(2)*(ABS(V1));
V3:=100-100-(3)*(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),20,1),15,1));
V4:=100-100-(3)*(SMA(((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*(100),20,1),15,1));
V5:=(HIGH+LOW+CLOSE)/(3);
V6:=(V5-MA(V5,10))/((0.015)*(AVEDEV(V5,10)));
V7:=(V5-MA(V5,30))/((0.015)*(AVEDEV(V5,30)));
V8:=IF((V6>=150) AND (V6<200) AND (V7>=150) AND (V7<200),10,0);
V9:=IF((V6<=(-150)) AND (V6>(-200)) AND (V7<=(-150)) AND (V7>(-200)),(-10),V8);
VA:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VB:=100-ABS(VA);
VC:=(3)*(SMA(((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55)))*(100),20,1))-(2)*(SMA(SMA(((INDEXC-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55)))*(100),20,1),15,1));
VD:=(3)*(SMA(((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55)))*(100),20,1))-(2)*(SMA(SMA(((INDEXO-LLV(INDEXL,55))/(HHV(INDEXH,55)-LLV(INDEXL,55)))*(100),20,1),15,1));
VE:=(REF(LOW,1))*(0.9);
VF:=(LOW)*(0.9);
顶线:=IF((VB<90),VB,100);
多方:IF((V1>0),V1,0),LINESTICK,CoLorFF00FF;
空方:(-IF((V1<0),V2,0)),LINESTICK,CoLorF0F000;
预警系统:IF(((V7>=200) AND (V6>=150) or CROSS(65,多方)),15,IF((V7<=(-200)) AND (V6<=(-150)),(-15),V9))+65,CoLor000000;
大趋势:=V3;
STICKLINE((V3<=REF(V4,1)),V3,V4,8,0),CoLor00FF00;
STICKLINE((V3>REF(V4,1)),V3,V4,8,0),CoLor0000FF;
T1:=(CLOSE>MA(CLOSE,20)) AND (MA(CLOSE,20)>=REF(MA(CLOSE,20),1));
T2:=CLOSE;
T3:=(多方>60) AND (预警系统>65) AND (顶线=100);
T4:=(多方>48) AND (预警系统>65) AND (顶线<100);
T5:=(空方<(-38)) AND (预警系统<65);
T7:=(V3>REF(V4,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
T8:(V3<=REF(V4,1)) AND CLOSE AND (空方>=REF(空方,1)) AND VC,CoLorFF0000;
DRAWTEXT(T1 AND (COUNT(T1,30)=1),10,'上升通道!'),CoLor00FFFF;
下降通道:DRAWTEXT(T2 AND (COUNT(T2,30)=1),80,'下降通道'),CoLorFFFFFF;
上涨过急:DRAWTEXT(T3 AND (COUNT(T3,30)=1),80,'上涨过急'),CoLor00FF00;
资金进场:DRAWTEXT(T7 AND (COUNT(T7,30)=1),(-10),'资金进场'),CoLor00FFFF;
DRAWTEXT(T8 AND (COUNT(T8,30)=1),90,'见顶回落'),CoLorF0F000;
A1:=((HHV(HIGH,50))/(LLV(LOW,100))>1.5);
A2:=(HHV(HIGH,50)-LOW)/(HHV(HIGH,50)-LLV(LOW,100));
A3:=(LOW-LLV(LOW,100))/(HHV(HIGH,50)-LLV(LOW,100));
A4:=(HHVBARS(HIGH,50)<LLVBARS(LOW,100));
A5:=A1 AND (A2>0.5) AND (A3>0.3) AND A4;
A6:=(COUNT(A5,20)=1);
反弹:IF(A6 AND A5,26,0),Stick,Linethick2,CoLor00FFFF;
DRAWTEXT(抢反弹,32,'抢反弹'),CoLor0099FF;
VAR2W:=100-((100)*(HHV(HIGH,14)-CLOSE))/(HHV(HIGH,14)-LLV(LOW,14));
MW:=EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:=EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND (M1<20);
抄底:IF(MB1,40,0),Linethick2,CoLorFFFFFF;
DRAWTEXT(抄底,62,'★'),CoLor00FFFF;
DRAWTEXT(抄底,52,'抄底 '),CoLorFF00FF;
A11:=MA(CLOSE,5);
A12:=MA(CLOSE,10);
A13:=MA(CLOSE,20);
A14:=MA(CLOSE,30);
均线多头排列:IF((A11>A12) AND (A12>A13) AND CROSS(A13,A14) ,25,0),Stick,Linethick2,CoLor00BBFF;
DRAWTEXT((A11>A12) AND (A12>A13) AND CROSS(A13,A14) ,35,'均线多头'),CoLorBBFFFF;
AAA:IF(T7 AND (COUNT(T7,30)=1),1,0);

通达信胜庄之宝指标公式

 

相关文章