在线检测未来函数

大智慧趋势先行主图指标公式

来源:Internet,编辑:股旁网,2015-07-07

DRAWGBK((C> 0),STRIP(RGB(10,15,30),RGB(10,10,10),0));
流通盘大小:=FINANCE2(37)/10000;
销售毛利率:=FINANCE2(12);
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(10,10,'流通盘大小:'+流通盘大小+'亿股 '),LINETHICK1,colorwhite;
DRAWTEXTABS(160,10,'销售毛利率:'+销售毛利率+'% '),LINETHICK1,colorwhite;
DRAWTEXTABS(290,10,'净利润同比增长:'+净利润同比增长+'% '),LINETHICK1,colorwhite;
当日换手率:=sum(100*v/capital,1);
DRAWTEXTABS(450,10,'当日换手率:'+NUMTOSTRN(sum(100*vOL/capital,1),2)+'%'),colorwhite,LINETHICK1;
五日换手率:=sum(100*vOL/capital,5);
DRAWTEXTABS(600,10,'五日换手率:'+NUMTOSTRN(五日换手率,2)+'%'),colorWHITE,LINETHICK1;
DRAWTEXTABS(750,10,STKLABEL+' '+STKNAME+''),Color00DDFF;
Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200;
Var2:=SMA(Var1,3,1);
Var3:=SMA(Var2,3,1);
Var4:=3*Var2-2*Var3;
Var5:=LLV(LOW,5);
Var6:=HHV(HIGH,5);
Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2;
Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2);
Var9:=3*Var7-2*Var8;
VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VarB:=POW(MA(LOW,5),2)+MA(LOW,5);
VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10;
VarE:=SMA(VarD,3,1)*1.5-100;
VarF:=SMA(VarE,3,1);
Var10:=3*VarE-2*VarF;
Var11:=(HIGH+LOW+CLOSE*2)/4;
Var12:=EMA(Var11,13);
Var13:=STD(Var11,13);
Var14:=(Var11-Var12)*100/Var13;
Var15:=EMA(Var14,5);
Var17:=EMA(Var15,13)+200-100;
Var18:=EMA(Var17,10);
Var19:=3*Var17-2*Var18;
Var1A:=Var2+Var7+VarE+Var17;
Var1B:=Var3+Var8+VarF+Var18;
Var1C:=Var4+Var9+Var10+Var19;
Var1D:=(HIGH+LOW+CLOSE)/3;
Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34));
Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
Var22:=(HIGH+LOW+CLOSE+Var1D)/4;
Var23:=EMA(Var22,24);
Var24:=STD(Var22,24);
Var25:=(Var22-Var23)/Var24*100;
Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24));
Var27:=EMA(Var25,5);
Var2A:=((Var27+Var26+Var20)/3+165)/4;
Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21;
Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15;
Var2D:=EMA(Var2C,13);{13}
Var2E:=(Var2A+Var2C)/2/1.1;
短期趋势:EMA(Var2E,3),colorwhite,linethick1,layer0 ;
辅助线:ema(短期趋势,5),coloryellow,layer0;
中期趋势:EMA((Var2B+Var2D)/2,2),colorRED,layer0;
判断线:ref(中期趋势,1),COLORCYAN,dotline,layer0;
分界线:50,colorgreen,dotline;
底部区域:0,dotline,color808080;
顶部区域:100,dotline,COLOR808080;
A33:=EMA(IF(L<= LLV(L,40),SMA(ABS(L-REF(L,1)),40,1)/SMA(MAX(L-REF(L,1),0),40,1),0),3)*10;
庄家吸筹:STICKLINE(A33,0,-A33/2,6,0),Color00AAFF,LAYER1;
STICKLINE(A33,0,-A33/2,4,0),Color00CCFF,LAYER1;
STICKLINE(A33,0,-A33/2,2,0),Color00EEFF,LAYER1;
STICKLINE(A33,0,-A33/2,1,0),Color00FFFF,LAYER1;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR);
MDI:=((DMM * 100) / TR);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
派红包:STICKLINE((阶段底部 < 0),0,阶段底部/3,3,0),LINETHICK6,COLORRED;

大智慧趋势先行主图指标公式

 

相关文章