在线检测未来函数

通达信成交量个股评价指标公式

来源:Internet,编辑:股旁网,2015-10-22

M1:=5;
M2:=10;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);
DRAWTEXT_FIX(1,0.33,0.11,1,'【当日有利因素】'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.33,0.61,1,'【当日不利因素】'),COLORGREEN;
DRAWTEXT_FIX(1,0.02,0.11,1,'★B'),COLORYELLOW;
DRAWTEXT_FIX(1,0.02,0.61,1,'★S'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,5)),0.4,0.05,1,'C上穿5日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,10)),0.5,0.05,1,'C上穿10日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,20)),0.6,0.05,1,'C上穿20日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,60)),0.7,0.05,1,'C上穿60日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,60)),0.8,0.15,1,'芙蓉出水'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,120)),0.9,0.05,1,'C上穿120日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,240)),0.99,0.05,1,'C上穿240日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,5),MA(C,10)),0.6,0.11,1,'5上穿10日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V*180/FROMOPEN/REF(MA(V,5),1)>4,0.6,0.21,1,'虚拟量大4倍'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(V,5),MA(V,10)),0.7,0.21,1,'量5上量10'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,1) AND V/REF(MA(V,5),1)>2,0.8,0.21,1,'上涨放量'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND REF(C,2)>MA(C,10) AND L<=MA(C,10) AND C>MA(C,10),0.6,0.31,1,'回踩10日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND REF(C,2)>MA(C,20) AND L<=MA(C,20) AND C>MA(C,20),0.7,0.31,1,'回踩20日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND REF(C,2)>MA(C,60) AND L<=MA(C,60) AND C>MA(C,60),0.8,0.31,1,'回踩60日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND REF(C,2)>MA(C,120) AND L<=MA(C,120) AND C>MA(C,120),0.9,0.31,1,'回踩120日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND REF(C,2)>MA(C,240) AND L<=MA(C,240) AND C>MA(C,240),0.99,0.31,1,'回踩240日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,5),C),0.5,0.55,1,'C下穿5日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,10),C),0.6,0.55,1,'C下穿10日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,20),C),0.7,0.55,1,'C下穿20日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,60),C),0.8,0.55,1,'C下穿60日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,120),C),0.9,0.55,1,'C下穿120日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,120),C),0.99,0.55,1,'C下穿240日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,10),MA(C,5)),0.8,0.55,1,'5下穿10日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(C,60),MA(C,20)),0.99,0.55,1,'20下穿60日线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,1) AND V/REF(MA(V,5),1)>1.5,0.6,0.65,1,'下跌放量'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,1) AND V/REF(MA(V,5),1)<1,0.7,0.65,1,'下跌缩量'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(MA(V,10),MA(V,5)),0.8,0.65,1,'量5下量10'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND (H/REF(C,1))-(C/REF(C,1))>0.04,0.9,0.65,1,'小心避雷针'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) AND CROSS(C,MA(C,20)),0.6,0.15,1,'一阳穿三线'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND LAST(C<MA(C,5),2,1) AND C>REF(C,1)*1.02,0.99,0.4,1,'止跌反转'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND DOWNNDAY(C,3) AND C>REF(C,1)*1.02,0.99,0.5,1,'三阴后第一阳'),COLORYELLOW;
五日线角:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.03;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 五日线角>30 AND 五日线角<44 AND 五日线角>REF(五日线角,1),0.7,0.4,1,'五日线角大于30'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 五日线角>45 AND 五日线角<60 AND 五日线角>REF(五日线角,1),0.8,0.4,1,'五日线角大于45'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND 五日线角>60 AND 五日线角>REF(五日线角,1),0.85,0.4,1,'五日线角大于60'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND V*180/FROMOPEN/REF(MA(V,5),1)>4,0.5,0.4,1,'有可能涨停'),COLORYELLOW;
FV:=IF(BARSCOUNT(C)=0,9999999999,V*200/FROMOPEN);
创新高天数:=SUMBARS(REF(FV,1)-FV,0);
XG:=LONGCROSS(创新高天数,40,30) AND C>REF(C,1);
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND XG,0.6,0.4,1,'量创40新高'),COLORYELLOW;
A1:=MA(MAX(HHV(H,13),C),2);
A2:=MA(MAX(HHV(H,5),A1),2);
A3:=MA(MAX(HHV(H,3),A2),2);
A4:=MA(MIN(LLV(A3,13),A3),2);
A5:=MA(MIN(LLV(L,13),A4),2);
A6:=(A1+A4+A5)/3;
中线:EMA(SLOPE(MA(C,2),21)*20+MA(C,2),55),COLORGREEN,LINETHICK3;
长线:MA(中线,20);
AC:=IF(C>中线,C*0.98,L),COLORYELLOW;
短A:MA(AC,5);
A8:=IF(C>中线,A1,中线*1.02);
A9:=IF(C>中线,A2,中线*1.02);
A10:=IF(C>中线,A3,中线*1.02);
A11:=(A8+A9+A10)/3;
A12:=MA(A11,10);
短B:MA(短A,5),COLORYELLOW;
DRAWTEXT(CROSS(C,短B),短B,'★'),COLORRED;
DRAWTEXT(CROSS(C,中线),中线,'★'),COLORRED;
DRAWTEXT(CROSS(C,长线),长线,'★'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,MA(C,5)),0.4,0.01,1,'C上穿5日线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,短B),0.09,0.005,1,'上穿短B'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,中线),0.2,0.01,1,'上穿中线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(C,长线),0.09,0.19,1,'上穿长线'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C>REF(C,1) AND (C<=REF(C,1)*1.03),0.2,0.19,1,'收阳且小于3点'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND VOL>REF(VOL,1),0.09,0.39,1,'量大于昨同期'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C/中线<1.21,0.2,0.39,1,'乖离率小于1.2'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(短A,C),0.09,0.99,1,'下穿短A'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(中线,C),0.2,0.59,1,'下穿中线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND CROSS(长线,C),0.09,0.79,1,'下穿长线'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C<REF(C,1) AND (C<=REF(C,1)*0.98),0.2,0.79,1,'收阴且小于-2'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND VOL<REF(VOL,1),0.09,0.39,1,'量小于昨同期'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND C/中线>1.2,0.2,0.39,1,'乖离率大于1.2'),COLORGREEN;
T1:=CROSS(C,短B)AND EXIST(CROSS(中线,C),5);
T2:=CROSS(C,中线);
T3:=CROSS(C,长线);
T4:=C>REF(C,1) AND C/REF(C,1)<1.031;
T5:=V>REF(V,1)*FROMOPEN/240;
T6:=C/中线<1.21;
买入评分:=T1+T2+T3+T4+T5+T6;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),C,中线,3,1),COLORRED;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),长线,中线,2,0),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.03,0.11,1,买入评分);
{DRAWRECTREL(930,500,970,990,0);
DRAWRECTREL(930,CONST(990-买入评分*100),970,990,95);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.95,0.95,1,买入评分),COLORRED;
DRAWTEXT_FIX(1,0.98,0.75,1,'买入评分'),COLORYELLOW;}
T7:=CROSS(短A,C);
T8:=CROSS(中线,C);
T9:=CROSS(中线,C);
T10:=C/REF(C,1)<0.98;
T11:=V<REF(V,1)*FROMOPEN/240;
T12:=C/中线>1.2;
卖出评分:=T7+T8+T9+T10+T11+T12;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.03,0.61,1,卖出评分);
量比前1:=V/(REF(V,1)*FROMOPEN/240);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.04,0.33,1,量比前1);

通达信成交量个股评价指标公式

 

相关文章