在线检测未来函数

通达信柱状均线主图指标公式

来源:Internet,编辑:股旁网,2016-02-12

{基本资料}
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
{}
DRAWTEXT_FIX(1,0.008,0.01,0,'基本资料:'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.06,0,'品种类型:'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.11,0,'行业板块:'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.16,0,'上市天数:'),COLOR656565;
DRAWNUMBER_FIX(1,0.065,0.16,0,上市天数),COLOR656565;
DRAWTEXT_FIX(1,0.095,0.16,0,'天'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.21,0,'股东人数:'),COLOR656565;
DRAWNUMBER_FIX(1,0.065,0.21,0,股东人数),COLOR656565;
DRAWTEXT_FIX(1,0.11,0.21,0,'人'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.26,0,'人均持股:'),COLOR656565;
DRAWNUMBER_FIX(1,0.065,0.26,0,人均持股),COLOR656565;
DRAWTEXT_FIX(1,0.1,0.26,0,'股'),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.31,0,'地区板块:'),COLOR656565;
DRAWTEXT_FIX(1,0.065,0.31,0,DYBLOCK),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.36,0,'概念板块:'),COLOR656565;
DRAWTEXT_FIX(1,0.065,0.36,0,GNBLOCK),COLOR656565;
DRAWTEXT_FIX(1,0.008,0.41,0,'风格板块:'),COLOR656565;
DRAWTEXT_FIX(1,0.065,0.41,0,FGBLOCK),COLOR656565;
{}
DRAWTEXT_FIX(品种类型=1,0.065,0.06,0,'沪 深 A 股'),COLOR656565;
DRAWTEXT_FIX(品种类型=2,0.054,0.06,0,' 中 小 板'),COLOR656565;
DRAWTEXT_FIX(品种类型=3,0.065,0.06,0,' 创 业 板'),COLOR656565;
DRAWTEXT_FIX(1,0.065,0.1,0,HYBLOCK),COLOR656565;{行业板块}
{数值}
{所属板块}
{业绩指标}
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
收入同比:=FINANCE(44);{主营收入同比增长率}
利润同比:=FINANCE(43);{净利润同比增长率}
{}
DRAWTEXT_FIX(1,0.13,0.01,0,'业绩资料:'),COLOR656565;
DRAWTEXT_FIX(1,0.13,0.06,0,'净资产收益率:'),COLOR656565;
DRAWNUMBER_FIX(1,0.25,0.06,0,净资收益率),COLOR656565;
DRAWTEXT_FIX(1,0.13,0.11,0,'主营业务利润率:'),COLOR656565;
DRAWNUMBER_FIX(1,0.25,0.11,0,主营利润率),COLOR656565;
DRAWTEXT_FIX(1,0.13,0.16,0,'现金流动负债比:'),COLOR656565;
DRAWNUMBER_FIX(1,0.25,0.16,0,现金负债比),COLOR656565;
DRAWTEXT_FIX(1,0.13,0.21,0,'主营收入同比增长率:'),COLOR656565;
DRAWNUMBER_FIX(1,0.25,0.21,0,收入同比),COLOR656565;
DRAWTEXT_FIX(1,0.13,0.26,0,'净利润同比增长率:'),COLOR656565;
DRAWNUMBER_FIX(1,0.25,0.26,0,利润同比),COLOR656565;
{财务指标}
每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));
每股收益年:=CONST(FINANCE(33));
每股收益:=CONST(FINANCE(38));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
{}
DRAWTEXT_FIX(1,0.3,0.01,0,'财务资料:'),COLOR656565;
DRAWTEXT_FIX(1,0.3,0.06,0,'每股收益:'),COLOR656565;
DRAWNUMBER_FIX(1,0.41,0.06,1,每股收益),COLOR656565;
DRAWTEXT_FIX(1,0.30,0.11,0,'每股净资产:'),COLOR656565;
DRAWNUMBER_FIX(1,0.41,0.11,1,每股净资产),COLOR656565;
DRAWTEXT_FIX(1,0.30,0.16,0,'每股现金流:'),COLOR656565;
DRAWNUMBER_FIX(1,0.41,0.16,1,每股现金流),COLOR656565;
DRAWTEXT_FIX(1,0.30,0.21,0,'每股未分配:'),COLOR656565;
DRAWNUMBER_FIX(1,0.41,0.21,1,每股未分配),COLOR656565;
DRAWTEXT_FIX(1,0.30,0.26,0,'每股公积金:'),COLOR656565;
DRAWNUMBER_FIX(1,0.41,0.26,1,每股公积金),COLOR656565;
PMA:MA(C,30),COLORWHITE,LINETHICK2,NODRAW;
IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
STICKLINE(C>=PMA,H,PMA,0,1),COLOR4D4DFF;
STICKLINE(C>=PMA,C,PMA,0,1),COLOR4D4DFF;
IF(PMA<REF(PMA,1),PMA,DRAWNULL),COLORFF6666,LINETHICK2,NODRAW;
STICKLINE(C<=PMA,C,PMA,0,1),COLOR006F00;
STICKLINE(C<=PMA,H,PMA,0,1),COLORFF4444;
PMA1:MA(C,13),COLORWHITE,LINETHICK2,NODRAW;
IF(PMA1>REF(PMA1,1),PMA1,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
STICKLINE(C>=PMA1,H,PMA1,0,1),COLORFF00FF;
STICKLINE(C>=PMA1,C,PMA1,1,1),COLOR871F78;
IF(PMA1<REF(PMA1,1),PMA1,DRAWNULL),COLORFF6666,LINETHICK2,NODRAW;
STICKLINE(C<=PMA1,C,PMA1,1,1),COLOR005F00;
STICKLINE(C<=PMA1,H,PMA1,1,1),COLOR005F00;
STICKLINE(C>=O,H,L,0.1,0),COLORRED;
STICKLINE(C>=O,C,O,2,1),COLORRED;
STICKLINE(C<O,H,L,0.1,0),COLORFF4444;
STICKLINE(C<O,C,O,2,1),COLORFF4444;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(2*CLOSE+LOW+OPEN+HIGH)/5;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
急速超跌:(CLOSE-MA(CLOSE,22))/MA(CLOSE,22)*100<-14,COLORFFFFFF,NODRAW;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),REF(IF(红色持股,JRL,DRAWNULL),1),REF(IF(红色持股,JRL,DRAWNULL),1),20,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),REF(IF(青色观望,JRH,DRAWNULL),1),REF(IF(青色观望,JRH,DRAWNULL),1),20,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(VAR1A,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(VAR1A,O,O+CO/3,2,0),COLOR880088;
STICKLINE(VAR1A,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(VAR1A,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(VAR1A,O,O+CO/3,0.5,0),COLOREE00EE;
MA13:MA(C,5),COLOR00FF00,LINETHICK2;
IF(MA(C,5)>=REF(MA(C,5),1),MA(C,5),DRAWNULL),COLORRED,LINETHICK2;
ZJ1:=MA("KDJ.J#WEEK"(34,9,3) ,5);
YK:=MA("KDJ.K#MONTH"(34,9,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(34,9,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(34,9,3),20);
ZK:=MA("KDJ.K#WEEK"(34,9,3) ,5),LINETHICK0;
ZD:=MA("KDJ.D#WEEK"(34,9,3) ,5),LINETHICK0;
RSV33:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV33,9,1),LINETHICK0;
DD:=SMA(K,3,1),LINETHICK0;
J:=3*K-2*DD,LINETHICK0;
GG1:=C>0;
RJC:DRAWICON(CROSS(K,DD),L*0.98,1);
DRAWTEXT(RJC,L*0.93,'金叉'),COLOR4D4DFF;
RSC:DRAWICON(CROSS(DD,K),H*1.03,2),;
DRAWTEXT(RSC,H*1.05,'死叉'),COLORFFFFFF;
T00:=200;
AF1:=300;
FX:=IF(C>REF(C,1),1,IF(C<REF(C,1),-1,0));
TT:=IF(PERIOD=0,BARSLAST(HOUR=9 AND MINUTE=31)+1,T00);
最高价:=CONST(HHV(H,TT));
最低价:=CONST(LLV(L,TT));
单位:=CONST((最高价-最低价)/40);
多方:=SUM(IF(FX=1,V,0),TT)/SUM(V,TT)*100;
空方:=SUM(IF(FX=-1,V,0),TT)/SUM(V,TT)*100;
平衡:=SUM(IF(FX=0,V,0),TT)/SUM(V,TT)*100;
DRAWTEXT_FIX(1,0.005,0.9,0,STRCAT(STRCAT(STRCAT('多方:%',CON2STR(多方,1)),
STRCAT('平衡:',CON2STR(平衡,1))),STRCAT('空方:%',CON2STR(空方,1)))),COLORYELLOW;
DRAWTEXT_FIX(1,0.005,0.85,0,STRCAT('最小单位:',CON2STR(单位,3))),COLORLIGRAY;

通达信柱状均线主图指标公式

 

相关文章