在线检测未来函数

通达信夫为妻纲指标公式

来源:Internet,编辑:股旁网,2016-06-14

X_1:=1560130;
X_2:=IF(DATE<X_1,1,0);
X_3:=1;
X_4:=WINNER(CLOSE)*100;
X_5:=EMA((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),5)*X_3;
大丈夫:(X_5+100)*X_3,COLORYELLOW,LINETHICK2;
X_6:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
贤内助:SMA(X_6,5,1)*X_3,COLORMAGENTA,LINETHICK3;
X_7:=SMA((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100,2,1);
熊孩子:SMA(X_7,2,1)*X_3,COLORCYAN;
X_8:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
X_9:=100+(-ABS(X_8));
X_10:=ABS(X_8);
红柱:STICKLINE(CROSS(熊孩子,X_10)*X_3,3,30,2,0),COLORRED;
绿柱:STICKLINE(CROSS(熊孩子,X_9)*X_3,70,100,2,0),COLORGREEN;
X_11:=AMOUNT/VOL/100;
DRAWICON(X_4<10 AND 大丈夫<10 AND 贤内助<5 AND CROSS(X_4>REF(X_4,1) AND X_3,0.618),20,1);
DRAWICON(大丈夫>90 AND 贤内助>90 AND CROSS(大丈夫<REF(大丈夫,1) AND 贤内助<REF(贤内助,1),0.382) AND X_3,80,2);
DRAWICON(TIME2>94500 AND TIME2<130000 AND 大丈夫<3 AND 贤内助<3 AND 熊孩子<3 AND X_3,50,24);
DRAWICON(TIME2>130000 AND 大丈夫<3 AND 贤内助<3 AND 熊孩子<3 AND X_3,50,25);
DRAWICON(TIME2>94000 AND 大丈夫>97 AND 贤内助>97 AND 熊孩子>97 AND X_3,50,15);
DRAWICON(TIME2>130000 AND 大丈夫<2 AND 贤内助<1 AND 熊孩子<1 AND X_3,60,7);
DRAWICON(TIME2>94000 AND 大丈夫>98 AND 贤内助>99 AND 熊孩子>99 AND X_3,60,8);
危险:90,COLORCC6633,LINETHICK2;
警戒:80,COLORFF80FF;
次险:75,COLORGREEN;
过渡:20,COLORGREEN;
安全:10,COLORFF80FF,LINETHICK2;
见底:0,COLORCC6633,LINETHICK2;
青线:熊孩子-REF(熊孩子,1),NODRAW,COLORCYAN;
黄线:大丈夫-REF(大丈夫,1),NODRAW,COLORYELLOW;
紫线:贤内助-REF(贤内助,1),NODRAW,COLORMAGENTA;
乖离:CLOSE/X_11*1000-1000,NODRAW,COLORYELLOW;

通达信夫为妻纲指标公式

 

相关文章