在线检测未来函数

通达信MACD量线金叉指标公式

来源:Internet,编辑:股旁网,2016-10-31

DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORFFFFFF,LINETHICK1;
DEA:EMA(DIFF,9),COLOR00FFFF,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:2*(DIFF-DEA),COLORRED,LINETHICK0;
MACD2:SMA(MACD1,0,3),COLORFFFF00,LINETHICK0;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLOR00FFFF;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR40FF00;
S1:=MACD<0;
S2:= (MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:=CROSS(DIFF,DEA) AND S5;
下成立:=CROSS(DIFF,DEA) AND S6;
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:CROSS(L1,L2) AND L5,LINETHICK0,COLORD6FF9C;
STICKLINE(变盘,5,-5,4,1),COLORD6FF9C;
成立距今:BARSLAST(CROSS(DIFF,DEA)),LINETHICK0;
L6:=BARSCOUNT(CLOSE);
DRAWTEXT(CROSS(L1,L2),DIFF,'买'),COLOR0000FF;
DRAWTEXT(CROSS(L2,L1),DIFF,'卖'),COLORFFFF00;
REF(DEA,S3),POINTDOT,COLORGREEN;
IF(L1>L2,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORB078FF;
IF(MACD<0,REF(DEA,S3),0),POINTDOT,LINETHICK5,COLORGREEN;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
XG1:CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;
XG2:CROSS(DIFF,DEA),LINETHICK0;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,LINETHICK0;
DRAWTEXT(绿柱短了,MACD,'绿柱短了'),COLOR00FF80;

通达信MACD量线金叉指标公式

 

相关文章