在线检测未来函数

通达信123战法修正主图指标公式

来源:Internet,编辑:股旁网,2017-03-07

笔周期:=10;
半分位:=50;
趋势:=1;
涨停位:=50;
时间:=1;
日线:=IF(PERIOD=5,1,0);
CA3:=REF(C,1)*日线;
涨停:=C/CA3>1.09;
STICKLINE(涨停,H*1.01,L*0.99,4,-1),COLORYELLOW;
跌停:=CA3/C>1.09;
STICKLINE(跌停,H*1.01,L*0.99,4,-1),COLORCYAN;
DRAWKLINE(H,O,L,C);
A1:=REF(H,3)=HHV(H,笔周期*3+1)*1;
B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);
D1:=FILTER(C1,3);{高点}
A2:=REF(L,3)=LLV(L,笔周期*3+1)*1;
B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);
D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(L,2*3),1)+REF(HHV(H,2*3),1))/2;
E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
H2:=D1 AND NOT(D2 AND E1>=E2);
L1:=D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,100000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1;
DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1;
J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);
J2:=J1>REF(J1,1);
A3:=H;
B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
D3:=A3 AND B3 AND HD;
E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
HH:=E3>REF(E3,1);
A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
B4:=REF(L,REF(BARSLAST(LD),1)+1);
D4:=A4 AND B4 AND LD;
E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
LL:=E4>REF(E4,1);
H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X3:=REF(BARSLAST(H3),1)+1;
F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);
LZ:=I3>REF(I3,1);
L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1;
F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);
K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);
XXQ:=WWQ>REF(WWQ,1);
下轨:DRAWLINE(XX,L,VV,L,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);
XX3Q:=WW3Q>REF(WW3Q,1);
WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);
XX4Q:=WW4Q>REF(WW4Q,1);
上轨:DRAWLINE(XX2,H,VV2,H,1)*画趋势,COLORMAGENTA,LINETHICK1;{画趋势线}
上轨1:=DRAWLINE(XX2,H,VV2,H,1);
Q0:=BARSLAST(XX2>0);
Q1:=BARSLAST(XX>0);
Q2:=BARSLAST(WW2>0);
Q3:=BARSLAST(VV>0);
Q4:=BARSLAST(XXQ>0);
Q5:=BARSLAST(XX3Q>0);
Q6:=BARSLAST(XX4Q>0);
OA周:=Q0-Q1+1;AB周:=Q1-Q2+1;BC周:=Q2-Q3+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.12,0.01,1,STRCAT('◆―A:',STRCAT(CON2STR(OA周,0),'天')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.12,0.08,1,STRCAT('A―B:',STRCAT(CON2STR(AB周,0),'天')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.12,0.16,1,STRCAT('B―C:',STRCAT(CON2STR(BC周,0),'天')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.12,0.24,1,STRCAT('C-----:',STRCAT(CON2STR(Q3+1,0),'天')))COLORYELLOW;
{123周期}
Z01:=Q1-Q0+1;Z12:=Q0-Q3+1;Z23:=Q3-Q2+1;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.12,0.01,1,STRCAT('◎―1:',STRCAT(CON2STR(Z01,0),'天')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.12,0.08,1,STRCAT('1―2:',STRCAT(CON2STR(Z12,0),'天')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.12,0.16,1,STRCAT('2―3:',STRCAT(CON2STR(Z23,0),'天')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.12,0.24,1,STRCAT('3-----:',STRCAT(CON2STR(Q2+1,0),'天')))COLORYELLOW;
低1:REF(L,BARSLAST(VV)),LINETHICK2,COLORGREEN;低壹:=REF(C,BARSLAST(VV));低壹1:=REF(C,BARSLAST(VV)+1);
高1:REF(H,BARSLAST(VV2)),LINETHICK2,COLORRED;高壹:=REF(C,BARSLAST(VV2));高壹1:=REF(C,BARSLAST(VV2)+1);
低2:REF(L,BARSLAST(XX)),DOTLINE,COLORGREEN;低贰:=REF(C,BARSLAST(XX));低贰2:=REF(C,BARSLAST(XX)+1);
高2:REF(H,BARSLAST(XX2)),DOTLINE,COLORRED;高贰:=REF(C,BARSLAST(XX2));高贰2:=REF(C,BARSLAST(XX2)+1);
低3:REF(L,BARSLAST(XXQ)),DOTLINE,COLORGREEN;
高3:REF(H,BARSLAST(XX3Q)),DOTLINE,COLORRED;
高4:REF(H,BARSLAST(XX4Q)),DOTLINE,COLORRED;
中位1:低1-(低1-高1)*(0.01*半分位),COLORRED;
STICKLINE(VV,高1,低1,0,1),COLORRED;
STICKLINE(VV2,高1,低1,0,0),COLORRED;
ABC:=IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN;
①②③:=IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN;
笔:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1;
{ABC涨跌}
OA幅:=(低贰-高贰2)/高贰2*100;AB幅:=(高壹-低贰2)/低贰2*100;BC幅:=(低壹-高壹1)/高壹1*100;AO幅:=(C-低壹1)/低壹1*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.01,0,STRCAT('跌',STRCAT(CON2STR(OA幅,2),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.08,0,STRCAT('涨',STRCAT(CON2STR(AB幅,2),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.16,0,STRCAT('跌',STRCAT(CON2STR(BC幅,2),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)>Q4,0.14,0.24,0,STRCAT('涨',STRCAT(CON2STR(AO幅,2),'%')))COLORYELLOW;
{123涨跌}
D01:=(高贰-低贰2)/低贰2*100;D12:=(低壹-高贰2)/高贰2*100;D23:=(高壹-低壹1)/低壹1*100;D30:=(C-高壹1)/高壹1*100;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.01,0,STRCAT('涨',STRCAT(CON2STR(D01,2),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.08,0,STRCAT('跌',STRCAT(CON2STR(D12,2),'%')))COLOR00FF00;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.16,0,STRCAT('涨',STRCAT(CON2STR(D23,2),'%')))COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(Q5)<Q4,0.14,0.24,0,STRCAT('跌',STRCAT(CON2STR(D30,2),'%')))COLORYELLOW;
DRAWTEXT( VV=1 AND Q0>Q1,L,'C')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0>Q1,H,'B')COLORMAGENTA;
DRAWTEXT( XX=1 AND Q0>Q1,L,'A')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆')COLORMAGENTA;
DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'★')COLORMAGENTA;
DRAWTEXT( VV=1 AND Q0<Q1,L,'2')COLORMAGENTA;
DRAWTEXT(VV2=1 AND Q0<Q1,H,'3')COLORMAGENTA;
DRAWTEXT(XX2=1 AND Q0<Q1,H,'1')COLORMAGENTA;
DRAWTEXT(XX=1 AND Q5<Q4,L,'◎')COLORMAGENTA;
DRAWTEXT(XX3Q=1 AND Q5<Q4,H,'☆')COLORMAGENTA;
V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;
V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;
V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;
V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;
XG1:= V1 OR V2 OR V3 OR V4;
XG2:= C > REF(HIGH,1);
XG:=XG1 AND XG2;
一阳定势:=CROSS(C,高1) AND CROSS(C,高2) AND CROSS(C,①②③),COLORYELLOW,NODRAW;
STICKLINE(一阳定势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(一阳定势=1,L,'一阳定势'),COLORYELLOW;
收敛:=ABC>0 AND ABC<低2 AND 低2<低1 AND 高2>高1 AND CROSS(C,上轨1);
STICKLINE(收敛,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(收敛=1,L,'收敛'),COLORYELLOW;
强势:=ABC>0 AND ABC<低2 AND 低2<低1 AND 高2<高1 AND CROSS(C,高1);
STICKLINE(强势,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(强势=1,L,'强势'),COLORYELLOW;
三买:=(低1>高2 AND 中位1>低1 AND XG>0 AND C>O),COLORYELLOW,NODRAW;
STICKLINE(三买,OPEN,CLOSE,2.8,1),COLORMAGENTA;
DRAWTEXT(三买=1,L,'三买'),COLORYELLOW;
{涨停向右画线}
涨停线:=REF(L+(H-L)*(0.01*涨停位),BARSLAST(CONST(BARSLAST(IF(CURRBARSCOUNT<=30*日线,涨停,0)))+1=CURRBARSCOUNT)),DOTLINE,COLORYELLOW;
涨停幅:=(L-涨停线)/涨停线*100,NODRAW;
日期:=VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VAR2STR(YEAR,0),'年'),VAR2STR(MONTH,0)),'月'),VAR2STR(DAY,0)),'日');
价格1:=VARCAT(VAR2STR(REF(C,CURRBARSCOUNT=CONST(1)),2),'元');
日期价格1:=VARCAT(日期,价格1);
DRAWTEXT(CURRBARSCOUNT=CONST(BARSLAST(VV*时间))+1,L*0.99,日期价格1),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=CONST(BARSLAST(VV2*时间))+1,H,日期价格1),COLORYELLOW,DRAWABOVE;
DRAWTEXT(CURRBARSCOUNT=CONST(BARSLAST(XX*时间))+1,L*0.99,日期价格1),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=CONST(BARSLAST(XX2*时间))+1,H,日期价格1),COLORYELLOW,DRAWABOVE;

通达信123战法修正主图指标公式

 

相关文章