在线检测未来函数

通达信量能指导指标公式

来源:Internet,编辑:股旁网,2017-10-31

Q1:=V/((H-L)*2-ABS((C-O)));
成交:=V;
买盘:=IF(C>O,Q1*(H-L),IF(C<O,Q1*((H-O)+(C-L)),V/2));
卖盘:=IF(C>O,(0-Q1*((H-C)+(O-L))),IF(C<O,0-Q1*(H-L),0-V/2));
买卖差:=买盘+卖盘;
量比1:=V/MA(V,5);
Q10:=买盘;
Q20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(121>JX1 AND JX1>0,JX1,120);
JY2:=IF(4>JX1 AND JX1>0,JX1,3);
Q30:=MA(V,JY2);
动神:=买盘;
鬼力:=Q20;
神比:=动神/Q30;
鬼比:=鬼力/Q30;
Q2:=H-L;
Q3:=ABS((O-C));
Q4:=H-IF(C>O,C,O);
Q5:=IF(C>O,O,C)-L;
Q6:=Q3/Q2*V;
Q7:=Q4/Q2*V;
Q8:=Q5/Q2*V;
Q9:=IF((V/CAPITAL>0.001),1,EXP(ABS(LOG(((V/CAPITAL)*100)))));
QA:=(((C-MA(C,5))/MA(C,5))*100);
QB:=(((MA(C,5)>MA(C,10)) AND (MA(C,10)>MA(C,30))) AND (MA(C,30)>MA(C,60)));
QC:=((MA(C,5)<MA(C,10)) AND (MA(C,10)<MA(C,30)));
QD:=REF(C,1);
QE:=((SMA(MAX((C-QD),0),6,1)/SMA(ABS((C-QD)),6,1))*100);
Q40:=((IF((Q6>=Q7 AND Q6>=Q8) AND C>O,Q6,动神)+动神)/2);
Q41:=((IF((Q7>Q6 AND Q7>Q8),Q7,动神)+动神)/2);
Q42:=((IF((Q8>Q6 AND Q8>Q7),Q8,动神)+动神)/2);
Q50:=((IF(((Q6>=Q7 AND Q6>=Q8) AND (C<O)),Q6,鬼力)+鬼力)/2);
三日上攻:=MA((Q40+Q41+Q42)/3,JY2),NODRAW;
三日下攻:=MA(Q50,JY2),NODRAW;
多头:STICKLINE(C>MA(C,30),0,V,2.4,-1),COLORRED;
空头:STICKLINE(C<MA(C,30),0,V,2.4,-1),COLORGREEN;
STICKLINE(鬼力>0,鬼力,0,3,0),COLORFF3399;
加仓:STICKLINE(Q6>=Q7 AND Q6>=Q8 AND C>O,0,Q6,2.2,0),COLORYELLOW;
减仓:STICKLINE(Q6>=Q7 AND Q6>=Q8 AND C<O,0,Q6,2.2,0),COLORBLUE;
洗盘:STICKLINE(Q8>Q6 AND Q8>Q7,0,Q8,2.2,0),COLORWHITE;
高卖:STICKLINE(Q7>Q6 AND Q7>Q8,0,Q7,2.2,0),COLORMAGENTA;
相对地量:=STICKLINE(Q9>2 AND V<MA(V,5)/2,0,V,3,0);
STICKLINE(买卖差>0,0,买卖差,1.0,0),COLORRED;
STICKLINE(买卖差<0,0,买卖差,2.2,0),COLORLIGREEN;
STICKLINE(REFDATE(V,DATE),REFDATE(V,DATE),REFDATE(V,DATE),1.6,1),COLORGRAY;
DRAWTEXT_FIX(1,0.399,0.001,0,'★【操作解盘注意】:巨量有绿色下部(负交易量)时,说明主力出逃 ★'),COLORYELLOW;
DRAWTEXT_FIX(1,0.399,0.056,0,'★ 粉色烛,红芯长,庄家高抛低吸操作 ★'),COLORFF00FF;
DRAWTEXT_FIX(1,0.399,0.111,0,'★ 白色烛,红芯长,庄家洗盘找底振荡,伺机建仓 ★'),COLORLIGRAY;
DRAWTEXT_FIX(1,0.399,0.166,0,'★ 巨量绿,蓝烛长,趋势破,急离场;等跌,莫手痒 ★'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.399,0.221,0,'★ 蓝色烛,红芯短,巨量绿尾长,庄家拉高退场,趁机减仓 ★'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.397,0.267,0,'*******************************************************************'),COLORGRAY;
DRAWTEXT_FIX(1,0.001,0.001,0,'【买卖盘总金额 (手)】'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.001,0.056,0,'┃当日买卖总量 ======'),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.111,0,'┃当日主动买量 ======'),COLORMAGENTA;
DRAWTEXT_FIX(1,0.001,0.166,0,'┃当日主动卖量 ======'),COLORWHITE;
DRAWTEXT_FIX(1,0.001,0.221,0,'┃当日买卖之比 ======'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.001,0.276,0,'┃买入资金累计 万元: ='),COLORYELLOW;
DRAWTEXT_FIX(1,0.001,0.331,0,'┃卖出资金累计 万元: ='),COLORRED;
AA:=V/((H-L)*2-ABS(C-O));
主动买盘:=IF(C>O,AA*(H-L),IF(C<O,AA*((H-O)+(C-L)),V/2));
主动卖盘:=IF(C>O,AA*((H-C)+(O-L)),IF(C<O,AA*(H-L),V/2));
买卖比:=主动买盘/主动卖盘;
WJ:=(H+L+C)/3;
VD1:=IF(H=L,1,H-MAX(O,C));
VD2:=IF(H=L,1,MAX(C,O)-WJ);
VD3:=IF(H=L,1,MIN(O,C)-L);
VD4:=IF(H=L,1,WJ-MIN(C,O));
VD5:=V/IF(H=L,4,H-L);
VD6:=VD1*VD5;
VD7:=VD2*VD5;
VD8:=VD3*VD5;
VD9:=VD4*VD5;
买入量:=VD9+VD8;
卖出量:=VD6+VD7;
买入资金:=买入量*C/100;
卖出资金:=卖出量*C/100;
DRAWNUMBER_FIX(1,0.100,0.056,0,CONST(V)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.100,0.111,0,CONST(主动买盘)),COLORMAGENTA;
DRAWNUMBER_FIX(1,0.100,0.166,0,CONST(主动卖盘)),COLORWHITE;
DRAWNUMBER_FIX(1,0.100,0.221,0,CONST(买卖比)),COLORLIGREEN;
DRAWNUMBER_FIX(1,0.100,0.276,0,CONST(买入资金)),COLORYELLOW;
DRAWNUMBER_FIX(1,0.100,0.331,0,CONST(卖出资金)),COLORRED;
五天均线:MA(V,5),COLORWHITE,LINETHICK2;
十三均线:MA(V,13),COLORYELLOW,LINETHICK1;

通达信量能指导指标公式

 

相关文章