在线检测未来函数

通达信黄金坑抄大底指标公式

来源:Internet,编辑:股旁网,2018-04-03

N:=14;
MM:=6;
RR8:=MA(CLOSE,27);
RR9:=(CLOSE-RR8)/RR8*100;
RRA:=MA(RR9,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA<-10 AND RRB>3;
黄金坑:IF(RRD,-35,0),COLORYELLOW,LINETHICK3;
DRAWICON(RRD,-20,1);
VAR1:=MA(CLOSE,27);
VAR2:=(CLOSE-VAR1)/VAR1*100;
VAR3:=MA(VAR2,2);
VAR4:=BARSLAST(CROSS(-10,VAR3)=1);
VAR5:=VAR3<-10 AND VAR4>3;
贪嘴乐: IF(VAR3>REF(VAR3,1) AND VAR5 AND VAR3<-15,60,0),LINETHICK3,LINESTICK,COLORFFA2AF;
DRAWICON(贪嘴乐>=1.6,35,1);
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
PS1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
DRAWTEXT(黄金坑 AND PS1,105,'B'),COLORRED;
STICKLINE(黄金坑 AND PS1,40,0,2,0),COLORYELLOW;
VAR15:=CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
买入XG:IF(FILTER(VAR15,28),70,0)LINETHICK2,COLORLIMAGENTA;
获利1个点:=REF(C,1)*1.01,COLORRED,NODRAW;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
短期底部:=LLV(OPEN,30);
AA10A:=MA(CLOSE,10);
AA12:=MA(CLOSE,12);
BB10A:=((ATAN((AA10A - REF(AA10A,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
VAR6:=MA(VAR5,3);
VAR7:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3) / CAPITAL));
VAR8:=(((CLOSE - VAR7) / VAR7) * 100);
VAR9:=((((REF(VAR8,1) < (0 - 40)) AND (VAR8 > REF(VAR8,1))) AND (REF(VAR8,1) < REF(VAR8,2))) AND ((VAR8 - REF(VAR8,1)) >
2.5));
VARA:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARB:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARC:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),5,1) / SMA(ABS((CLOSE - VARD)),5,1)) * 100);
VARF:=(((HIGH + LOW) + CLOSE) / 3);
VAR10:=((VARF - MA(VARF,14)) / (0.015 * AVEDEV(VARF,14)));
VAR11:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100))
< (0 - 0.273));
VAR12:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
VAR13:=(VAR11 AND VAR12);
VAR14:=((((VARA >= (0 - 45)) AND (VARA <= (0 - 10))) AND (VARB <= (0 - 15))) AND (VARC <= (0 - 20)));
VAR16:=(VAR13 AND VAR15);
VAR17:=1;
VAB0:=531;VAB1:=1510000;VAB2:=VAB0 + VAB1; VAB3:=IF(DATE > VAB2,0,1);
VARA12:=SMA(H,10,9)*VAB3; VARA13:=SMA(L,10,9)*VAB3; VAR18:=(CLOSE * VOL);
VAR19:=EMA((((((MA(VAR18,4) / MA(VOL,4)) + (MA(VAR18,6) / MA(VOL,6))) + (MA(VAR18,13) / MA(VOL,13))) + (MA(VAR18,24) / MA
(VOL,24))) / 4),1);
VAR1A:=(1 * VAR19);
VAR1B:=(VAR19 * 0.92);
VAR1C:=EMA(CLOSE,34);
VAR1D:=MA((VAR1C * 1.12),5);
VAR1E:=MA((VAR1C * 0.82),5);
VAR1F:=(CLOSE < VAR1E);
VAR20:=((((((MA(AMOUNT,5) * VAR17) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA
(VOL,5)) / 100)) < ((0 - 0.4) * VAR17));
VAR21:=HHV(HIGH,500);
VAR22:=LLV(LOW,500);
VAR23:=HHV(HIGH,250);
VAR24:=LLV(LOW,250);
VAR25:=HHV(HIGH,125);
VAR26:=LLV(LOW,125);
VAR27:=MA(((((((VAR21 * 0.45) + (VAR23 * 0.5)) + VAR22) + VAR24) + VAR26) / 5),35);
VAR28:=MA((((VAR23 * 0.62) + VAR26) / 2),35);
VAR29:=MA((((VAR23 * 0.75) + VAR26) / 2),18);
VAR2A:=MA((((((VAR23 * 0.93) + (VAR27 * 2)) + (VAR28 * 1.8)) + (VAR29 * 1.5)) / 4),18);
VAR2B:=MA(((((VAR21 * 0.95) + (VAR27 * 3)) + (VAR28 * 2)) / 3),35);
VAR2C:=VAR27;
VAR2D:=VAR28;
VAR2E:=VAR29;
VAR2F:=VAR2A;
VAR30:=VAR2B;
VAR31:=((CLOSE - REF(MA(CLOSE,20),11)) < (0 - 2));
VAR32:=(INDEXA / 100000000);
VAR33:=INDEXADV;
VAR34:=INDEXDEC;
VAR35:=((VAR18 / (VAR18 + VAR19)) * VAR17);
VAR36:=((VAR19 / (VAR18 + VAR19)) * VAR17);
VAR37:=EMA(VAR35,10);
VAR38:=EMA(VAR36,10);
VAR39:=EMA(VAR37,10);
VAR3A:=EMA(VAR38,20);
VAR3B:=EMA(VAR37,3);
VAR3C:=EMA(VAR39,6);
VAR3D:=EMA(VAR3A,2);
VAR3E:=(VAR3C - VAR3D);
VAR3F:=(((VAR3C - REF(VAR3C,1)) > 0) AND ((REF(VAR3C,1) - REF(VAR3C,2)) < 0));
VAR40:=IF((CROSS(VAR3B,VAR3C) AND (VAR3C <= 20)),30,0);
VAR41:=VAR40;
VAR42:=(SMA(((AMOUNT / VOL) / 100),13,1) * 1.15);
VAR43:=(SMA(((AMOUNT / VOL) / 100),13,1) * 0.85);
VAR44:=(CLOSE - REF(MA(CLOSE,20),11));
VAR45:=(((((((((((((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43)) OR (((CLOSE < VAR1E) AND VAR31) AND VAR20)) OR ((CLOSE <
VAR1E) AND (CLOSE < VAR43))) OR (((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43))) OR (VAR20 AND (CLOSE < VAR2C))) OR ((VAR20
AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (CLOSE < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (CLOSE
< VAR43))) OR ((CLOSE < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((CLOSE < VAR1E) AND VAR31));
VAR46:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR47:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR48:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR49:=REF(CLOSE,1);
VAR4A:=((SMA(MAX((CLOSE - VAR49),0),5,1) / SMA(ABS((CLOSE - VAR49)),5,1)) * 100);
VAR4B:=(((HIGH + LOW) + CLOSE) / 3);
VAR4C:=((VAR4B - MA(VAR4B,14)) / (0.015 * AVEDEV(VAR4B,14)));
VAR4D:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100))
< (0 - 0.273));
VAR4E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
VAR4F:=(VAR11 AND VAR12);
VAR50:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)));
VAR51:=(COUNT(VAR50,1) >= 1);
VAR52:=(VAR4F AND VAR51);
VAR53:=(((((VAR20 AND (CLOSE < VAR1E)) AND VAR31) AND (CLOSE < VAR2C)) AND VAR45) AND VAR52);
VAR54:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR55:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR56:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR57:=REF(CLOSE,1);
VAR58:=((SMA(MAX((CLOSE - VAR57),0),5,1) / SMA(ABS((CLOSE - VAR57)),5,1)) * 100);
VAR59:=(((HIGH + LOW) + CLOSE) / 3);
VAR5A:=((VAR59 - MA(VAR59,14)) / (0.015 * AVEDEV(VAR59,14)));
VAR5B:=((((((VAR54 >= (0 - 15.8)) AND (VAR54 <= (0 - 12.2))) AND (VAR55 <= (0 - 20.8))) AND (VAR56 <= (0 - 27.5))) AND (VAR58
<= 11.7)) AND (VAR5A <= (0 - 145)));
VAR5C:=9.999999884842+026;
VAR5D:=(COST(10) * 0)*VAB3;
VAR5E:=((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100));
VAR5F:=MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5);
VAR60:=((CROSS((0 - 5),VAR5F) AND (VAR5E < (0 - 0.4))) AND (((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.19)));
VAR61:=MA(CLOSE,3);
VAR62:=(REF(CLOSE,2) * 0.865);
VAR63:=(REF(CLOSE,13) * 0.772);
VAR64:=MIN(VAR62,VAR63);
VAR65:=((100 * VOL) / CAPITAL);
VAR66:=MA(CLOSE,13);
VAR67:=IF(((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8)),1,0);
开始控盘:=STICKLINE((VAR6 <= (0 - 10)),0,(0 - 20),5,0)*VAB3,COLORBROWN;
出击:=IF(((((VAR9 OR VAR16) OR VAR53) OR VAR5B) OR ((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) <
1.8))),120,0),LINETHICK2,COLOR0000FF;
VAR68:=0;
VARQ:=MA(CLOSE,152);
VARW:=MA(CLOSE,194.16);
VAREE:=(VARW + (2 * STD(CLOSE,170)));
VARR:=(VARQ + (2 * STD(CLOSE,170)));
VART:=IF((DATE > 1080822),0,1);
VAR611:=EMA(HHV(HIGH,500),21);
VAR71:=EMA(HHV(HIGH,250),21);
VAR81:=EMA(HHV(HIGH,90),21);
VAR91:=EMA(LLV(LOW,500),21);
VARA1:=EMA(LLV(LOW,250),21);
VARB1:=EMA(LLV(LOW,90),21);
VARC1:=EMA((((((((VAR91 * 0.96) + (VARA1 * 0.96)) + (VARB1 * 0.96)) + (VAR611 * 0.558)) + (VAR71 * 0.558)) + (VAR81 * 0.558))
/ 6),21);
VARD1:=EMA((((((((VAR91 * 1.25) + (VARA1 * 1.23)) + (VARB1 * 1.2)) + (VAR611 * 0.55)) + (VAR71 * 0.55)) + (VAR81 * 0.65)) /
6),21);
VARE1:=EMA((((((((VAR91 * 1.3) + (VARA1 * 1.3)) + (VARB1 * 1.3)) + (VAR611 * 0.68)) + (VAR71 * 0.68)) + (VAR81 * 0.68)) /
6),21);
VARF1:=EMA((((((VARC1 * 3) + (VARD1 * 2)) + VARE1) / 6) * 1.738),21)*VAB3;
VAR101:=REF(LOW,1);
VAR111:=((SMA(ABS((LOW - VAR101)),3,1) / SMA(MAX((LOW - VAR101),0),3,1)) * 100);
VAR121:=EMA(IF(((CLOSE * 1.35) <= VARF1),(VAR111 * 10),(VAR111 / 10)),3)*VAB3;
VAR131:=LLV(LOW,30);
VAR141:=HHV(VAR121,30)*VAB3;
VAR151:=IF(MA(CLOSE,58),1,0);
VAR161:=((EMA(IF((LOW <= VAR131),((VAR121 + (VAR141 * 2)) / 2),0),3) / 618) * VAR151);
VAR171:=(((IF((VAR161 > 50),50,VAR161) / 20) * 15) * VART)*VAB3;
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,COLORRED,LINETHICK2;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,COLORGRAY;
震仓线:=45,COLORMAGENTA;
震仓线2:=50,COLORGRAY;
逃命线:=80,COLORRED;
抄底线:=20,COLORGREEN;
绝底线:=5,COLORBLUE;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线*VAB3;
财主抓板:=(((((COUNT((X31 = 1),4) = 3) AND (X31 = 0))AND O<C AND (((C-REF(C,1))/REF(C,1))>0.085))*89) >=89)OR((C-REF(C,1))/REF(C,1)>0.085 AND (REF(PP3,1) OR REF(PP,1))) AND VAB3=1,NODRAW,COLORYELLOW;
STICKLINE(财主抓板,5,10,1,0),COLORRED;
STICKLINE(财主抓板,10,15,1,0),COLORBLUE;
STICKLINE(财主抓板,15,20,1,0),COLORRED;
STICKLINE(财主抓板,20,25,1,0),COLORBLUE;
STICKLINE(财主抓板,25,30,1,0),COLORMAGENTA;
STICKLINE(财主抓板,30,35,1,0),COLORBROWN;
STICKLINE(财主抓板,35,40,1,0),COLORMAGENTA;
STICKLINE(财主抓板,40,45,1,0),COLORYELLOW;
STICKLINE(财主抓板,45,50,1,0),COLORLIRED;
STICKLINE(财主抓板,50,55,1,0),COLORYELLOW;
STICKLINE(财主抓板,55,60,1,0),COLORMAGENTA;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);{DMI指标}{N:2,90,14;MM:2,90,6;}
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
多头线: DMP*100/MTR,COLORCYAN,LINETHICK2;
空头线:= DMM*100/MTR,COLORGREEN,LINETHICK2;
趋势:= EXPMEMA(ABS(空头线-多头线)/(空头线+多头线)*100,MM),COLORYELLOW,LINETHICK2;
强弱:30,COLORWHITE,DOTLINE,LINETHICK1;
BOLL:=MA(CLOSE,20);
UB:=BOLL+2*STD(CLOSE,20);
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.025) AND((HIGH)/(CLOSE)<1.03) AND ((CLOSE)>(UB)) AND (多头线-空头线)>5 AND 多头线>20 AND (趋势>REF(趋势,1)) AND (多头线>REF(多头线,1)) AND (VAR3AA>0),91,0);
XG:=(FILTER((VAR4AA>90),21)),COLORYELLOW;
{DRAWTEXT(XG,85,'DMI'),COLOR00C5FF;
STICKLINE(XG,90,0,0.5,0),COLORMAGENTA;
STICKLINE(XG,90,0,0.5,0),COLORMAGENTA;
STICKLINE(XG,90,0,0.5,0),COLORMAGENTA;
STICKLINE(XG,90,0,0.3,0),COLORMAGENTA;}
VAR1Z:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2Z:=SUMBARS(VOL,CAPITAL);
VAR3Z:=HHV(VAR1Z,VAR2Z);
VAR4Z:=LLV(VAR1Z,VAR2Z);
VAR5Z:=(2*VAR1Z-VAR4Z-REF(VAR4Z,1))/(VAR3Z-VAR4Z);
VAR6Z:=(VAR1Z-VAR4Z)/(VAR3Z-VAR4Z);
VAR7Z:=IF(VAR1Z<=VAR4Z,VAR5Z*60,VAR6Z*60);
VAR8Z:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9Z:=EMA(VAR8Z,7);
VARAZ:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARBZ:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
大底: IF(VARAZ+VARBZ<7 AND CROSS(VAR8Z,VAR9Z) AND VAR9Z<-18 AND VAR9Z<VARBZ AND 黄金坑 AND 贪嘴乐,110,0),COLORRED,LINETHICK3;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
A:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
B:=BARSLAST(CROSS(GJTJ4,GJTJ2));
DD:=GJTJ3;
E:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
F:=GJTJ2;
B1:=A>0 AND REF(A,1)=0 AND REF(A,2)>0;
VAR0004:="KDJ.K#WEEK"(9,3,3);
VAR0005:="KDJ.D#WEEK"(9,3,3);
周:=CROSS(VAR0004,VAR0005);
周金坑KDJ:=IF(A AND B AND E AND F AND 周,50,0)COLORWHITE,LINETHICK1;
KKM:="KDJ.K#MONTH";
KDM:="KDJ.D#MONTH";
月:=CROSS(KKM,KDM);
去停牌:=DYNAINFO(8)>0;
去ST:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S'));
金坑K月:IF(A AND B AND DD AND E AND F AND 去停牌 AND 去ST AND 月,90,0)COLORWHITE,LINETHICK3;
VARO1:=HHV(HIGH,9)-LLV(LOW,9);
VARO2:=HHV(HIGH,9)-CLOSE;
VARO3:=CLOSE-LLV(LOW,9);
VARO4:=VARO2/VARO1*100-70;
VARO5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARO6:=(2*CLOSE+HIGH+LOW)/4;
VARO7:=SMA(VARO3/VARO1*100,3,1);
VARO8:=LLV(LOW,34);
VARO9:=SMA(VARO7,3,1)-SMA(VARO4,9,1);
VARO11:=HHV(HIGH,34);
VARO12:=EMA((VARO6-VARO8)/(VARO11-VARO8)*100,13);
VARO13:=EMA(0.667*REF(VARO12,1)+0.333*VARO12,2);
生命线:=EMA(VARO13,5),COLORYELLOW;
太平洋XG:=IF(CROSS(VARO12,VARO13) AND VARO12>VARO13,25,0)COLORYELLOW;
VAR0002:="KDJ.K#DAY"(9,3,3);
VAR0003:="KDJ.D#DAY"(9,3,3);
VAR0006:="KDJ.K#MONTH"(9,3,3);
VAR0007:="KDJ.D#MONTH"(9,3,3);
金叉:=IF(CROSS(VAR0002,VAR0003),40,0)LINESTICK,COLORGREEN;
VAR15H:=CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
XG88:=IF(FILTER(VAR15H,28),35,0)LINETHICK1,COLORWHITE;
VAR2G:=REF(LOW,1);
VAR3G:=SMA(ABS(LOW-VAR2G),3,1)/SMA(MAX(LOW-VAR2G,0),3,1)*100;
VAR4G:=EMA(IF(CLOSE*1.3,VAR3G*10,VAR3G/10),3);
VAR5G:=LLV(LOW,30);
VAR6G:=HHV(VAR4G,30);
VAR7G:=IF(MA(CLOSE,58),1,0);
VAR8G:=EMA(IF(LOW<=VAR5G,(VAR4G+VAR6G*2)/2,0),3)/618*VAR7G;
VAR9G:=IF(VAR8G>100,100,VAR8G);
底部吸筹指标:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100, , COLOR00FF00;
先知:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, , COLORFF00FF;
可能放量拉升:=IF(CROSS(底部吸筹指标,-24),1,0), , COLORFFFFFF;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);波段王:=SMA(VARK3,3,1), , COLORRED,LINETHICK2;
波段鬼:=SMA(波段王,2.5,1),COLORYELLOW,LINETHICK2;
趋势线L:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2
*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), ,
COLORFF6666,LINETHICK2;RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);DK1:=K1-REF(K1,1);
CS8:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
DDFX8:=(SMA(CS8,3,1)-50)*2;
DCS8:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*100;
C8:=(SMA(DCS8,3,1)-50)*2;
差值8:=DDFX8-C8;
出手就赢:=IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0) AND 差值8>REF(差值8,1);
VAR15G:=CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.011 OR CLOSE/REF(CLOSE,1)>1.048 AND CLOSE=HIGH AND BETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));
买入O:=IF(FILTER(VAR15G,28),25,0)LINETHICK2,COLORMAGENTA;
底部买赢:IF(出手就赢 AND 底部吸筹指标 AND 波段鬼 AND 买入XG,100,0)LINETHICK3,COLORBROWN;
赢XG:IF(太平洋XG AND 日金叉 AND XG88 AND 买入O AND 出手就赢,50,0)LINETHICK3,COLORLIRED;
{ZF:=(CLOSE/REF(CLOSE,1)-1)*100;
TA:=ZF>=5 AND CLOSE>OPEN;
TB:=RANGE(CLOSE,REF(LOW,1),REF(CLOSE,1)) AND OPEN>CLOSE;
TC:=REF(TA,1) AND TB;
TD:=BARSLAST(TC);
TE:=ZF>=1.5 AND CLOSE>OPEN AND RANGE(REF(OPEN,TD),REF(CLOSE,1),CLOSE);
TF:=EVERY(CLOSE>=REF(LOW,TD+1),TD);
封印:=TE AND TF;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
底部预警:=W4 AND COUNT(W4,5)=1;
跳空高开:=REF(C,1)<REF(O,1) AND O>REF(C,1) AND C>=REF(C,1)*1.02;
封印G:IF(封印 AND 跳空高开 AND 底部预警,40,0)COLORFFA2AF,LINETHICK3;}
量比:=V/REF(MA(V,1),1);
多方力度:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
空方力度:=100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));
红钻石:=C/REF(C,1)>1.03 AND 量比>1.1 AND CROSS(多方力度,空方力度);
DRAWICON(红钻石,L*0.98,25);
VAR1I:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;
VAR2I:=(C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100;
VAR3I:=(C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100;
VAR4I:=DMA(SMA((VAR1I+VAR2I+VAR3I)/3,2,1),3);
K:SMA(VAR4I,2,1),COLORRED,LINETHICK1;
M:SMA(K,2,1),COLORFFFFFF;
DRAWICON(CROSS(K,M),K-1,1);
DRAWICON(CROSS(M,K),M-1,2);
红买青卖:30,COLOR0000FF,LINETHICK1;
红买: IF(K>M,30,DRAWNULL),COLOR0000FF,LINETHICK1;
青卖: IF(K<M,30,DRAWNULL),COLOR00FF00,LINETHICK1;
{底部来临:}
VAR2P:=CLOSE*VOL;
VAR3P:=EMA((MA(VAR2P,3)/MA(VOL,3)+MA(VAR2P,5)/MA(VOL,5)+MA(VAR2P,13)/MA(VOL,13)+MA(VAR2P,21)/MA(VOL,21))/4,1);
VAR4P:=1*VAR3P;
VAR5P:=VAR3P*0.92;
VAR6P:=EMA(CLOSE,34);
VAR7P:=MA(VAR6P*1.12,5);
VAR8P:=MA(VAR6P*0.82,5);
VAR9P:=CLOSE<VAR8P;
VARAP:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<(-0.4);
XX:=VARAP AND CLOSE<VAR8P;
VAR10P:=REF(CLOSE,1);
VAR14P:=SMA(MAX(CLOSE-VAR10P,0),12,1)/SMA(ABS(CLOSE-VAR10P),12,1)*100;
CC:=CROSS(VAR14P,20);
底部来临:IF(XX AND CC,100,0)COLORYELLOW,LINETHICK2;

通达信黄金坑抄大底指标公式

 

相关文章