在线检测未来函数

通达信风险系数指标公式

来源:Internet,编辑:股旁网,2010-05-24

RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=Sma(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD,LINETHICK0,COLORYELLOW;{//变异kd风险系数}
TGLXS:=(TFXXS-REF(TFXXS,1))*10,LINETHICK0,COLORGREEN;{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS,LINETHICK0,COLORGREEN;{//变异KD预测风险}
{//——————【数值显示】}
风险系数:TFXXS,LINETHICK0,COLORYELLOW;
乖离系数:TGLXS,LINETHICK0,COLORGREEN;
预测风险:TYCFX,LINETHICK0,COLORCYAN;
stICKLINE(TGLXS>0,100,100+TGLXS,4,0),COLOR0000CC;
STICKLINE(TGLXS>0,100,100+TGLXS,3,0),COLOR0000DD;
STICKLINE(TGLXS>0,100,100+TGLXS,2,0),COLOR0000EE;
STICKLINE(TGLXS<0,100,100+TGLXS,3,0),COLOR00DD00;
STICKLINE(TGLXS<0,100,100+TGLXS,2,0),COLOR00EE00;
STICKLINE(TGLXS<0,100,100+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,100+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,100+TGLXS,8,0),COLORGREEN;
{风险系数}
IF(TFXXS<160 AND TFXXS>50,TFXXS,DRAWNULL),LINETHICK2,COLORFF66FF;
IF(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1),TFXXS,DRAWNULL),LINETHICK2,COLORWHITE;
IF(TFXXS<=50,TFXXS,DRAWNULL),LINETHICK2,COLORYELLOW;
IF(TFXXS>=160,TFXXS,DRAWNULL),LINETHICK2,COLORBLUE;
{预测风险}
IF(C>0,TYCFX,DRAWNULL),COLORCYAN;

通达信风险系数指标公式

相关文章