在线检测未来函数

通达信疯牛起爆涨停捉妖指标公式

来源:Internet,编辑:股旁网,2021-12-03

{使用说明:这是一个由资金进场、首板、启爆、疯牛涨停、涨停捉妖、初级战法等多个指标组合起来的副图,信号出现越密集越强势,成功率越高。}

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1011”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

{抓板资金监控}
ZBZJ1:=Dma((HIGH+LOW+CLOSE*2)/4,0.9);
ZBZJ2:=REF(EMA(ZBZJ1,3),1);
ZBZJ3:=vol/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
ZBZJ4:=IF(CLOSE>OPEN,ZBZJ3*(HIGH-LOW),IF(CLOSE<OPEN,ZBZJ3*(HIGH-OPEN+(CLOSE-LOW)),VOL/2))+IF(CLOSE>OPEN,0-ZBZJ3*(HIGH-CLOSE+(OPEN-LOW)),IF(CLOSE<OPEN,0-ZBZJ3*(HIGH-LOW),0-VOL/2));
ZBZJ5:=VOL/CAPITAL;
ZBZJ6:=IF(ZBZJ5>10,10,ZBZJ5);
ZBZJ7:=ZBZJ4/20/1.15;
ZBZJ8:=ZBZJ7*0.55+REF(ZBZJ7,1)*0.33+REF(ZBZJ7,2)*0.22;
ZBZJ9:=EMA(ZBZJ8,8);
ZBZJ10:=EMA(ZBZJ8,3);
资金净额:=(ZBZJ7*0.4-ZBZJ10*0.4)*C/60000;
成交额:=AMOUNT/100000000;
市值:=CLOSE*CAPITAL/1000000;
资金流占比:=资金净额*100/市值;
资金成占比:=资金净额*100/成交额;
资金1:=资金净额>0.4 AND 资金流占比>0.6 AND 资金成占比>15 AND 市值<50;
资金2:=资金净额>0.6 AND 资金流占比>0.4 AND 资金成占比>15 AND 市值>50;
资金3:=资金净额>0.6 AND 资金流占比>0.9 AND 资金成占比>18 AND 市值<50;
资金4:=资金净额>0.8 AND 资金流占比>0.6 AND 资金成占比>20 AND 市值>50;
资金5:=(资金1 OR 资金2)*5,COLORRED;
资金6:=资金3 OR 资金4;
stICKLINE(资金1 OR 资金2,42,46,2,0),COLOR00FFFF;
DRAWTEXT(资金1 OR 资金2,44,'资金进场+'),COLORRED;
{30 日首版}
N:=30;{N为时间段}
ZT:=C>=ZTPRICE(REF(C,1),0.1);
首板:=(COUNT(ZT,N)=1 AND ZT) AND C>O;
STICKLINE(首板,36,40,2,0),COLOR00FFFF;
{DRAWTEXT(CURRBARSCOUNT=25,38,'★首板★ '),COLORFF00FF;}
DRAWTEXT((COUNT(ZT,N)=1 AND ZT) AND C>O,38,'★首板★ '),COLORFF00FF;
{启爆超牛}
HM1:=ABS(((3.48*CLOSE+HIGH+LOW+O)/5-EMA(CLOSE,20))/EMA(CLOSE,20));
HM2:=DMA(((2.15*CLOSE+LOW+HIGH + O)/5),HM1);
妖股线:=EMA(HM2,200)*1.26 ,LINETHICK2,COLORGREEN;
牛熊线:=EMA(HM2,200)*1.18 ,LINETHICK2,COLORGREEN;
Q1:=MA((L+H+C)/3,5);
压力:=HHV(Q1,60),COLORCYAN,LINETHICK2;
AA:=IF((压力 >REF(压力,1)),压力,DRAWNULL),COLORCYAN,DOTLINE,LINETHICK2;
AHC1:=CLOSE*VOL;
AHC2:=EMA((expma(AHC1,3)/EXPMA(VOL,3)+EXPMA(AHC1,6)/EXPMA(VOL,6)+EXPMA(AHC1,12)/EXPMA(VOL,12)+EXPMA(AHC1,24)/EXPMA(VOL,24))/4,13),COLORYELLOW;
上轨:=1.06*AHC2,LINETHICK2,COLORWHITE;
顶:=1.13*AHC2,LINETHICK2,COLORWHITE;
MM:=MIN(AA,妖股线);
MM2:=MIN(上轨,妖股线);
KK:=MIN(AA,牛熊线);
KK2:=MIN(上轨,牛熊线);
ZE:=REF(C,1)*1.1-C<0.01 AND H=C;
启爆:=crOSS(C,上轨) AND ZE;
STICKLINE(启爆,30,34,2,0),COLOR0055EE;
{DRAWTEXT(CURRBARSCOUNT=25,32,'★启爆★ '),COLOR0055EE;}
DRAWTEXT(CROSS(C,上轨) AND ZE,32,'★启爆★ '),COLOR0055EE;
超牛:=CROSS(C,顶) AND ZE;
STICKLINE(超牛,24,28,2,0),COLOR00FF99;
{DRAWTEXT(CURRBARSCOUNT=25,26,'★超牛★ '),COLOR00FF99;}
DRAWTEXT(CROSS(C,顶) AND ZE,26,'★超牛★ '),COLOR00FF99;
{天天涨停}
VAR1:=DATE<61901232;
VAR2:=MA(CLOSE,5);
VAR3:=MA(CLOSE,10);
VAR4:=MA(CLOSE,20);
VAR5:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
VAR6:=IF(CLOSE-REF(CLOSE,1)*0.9<0.01,1,0);
VAR7:=IF(VAR1,EMA(REF(COST(95),0),2),DRAWNULL);
VAR8:=IF(VAR1,EMA(REF(COST(5),0),2),DRAWNULL);
VAR9:=REF(VAR7,1)/REF(VAR8,1)<1.13;
VAR10:=VAR9 OR (CLOSE>=0.985*VAR7 AND CLOSE/REF(CLOSE,1)>1.08);
VAR11:=100*WINNER(CLOSE)>=90 AND DYNAINFO(4)>0 AND BARSCOUNT(CLOSE)>200;
VAR12:=MA(CLOSE,30);
VAR13:=FILTER(VAR11,21) AND CLOSE>VAR12 AND CLOSE/REF(CLOSE,1)>=1.09;
VAR14:=VAR10 AND (VAR13 OR REF(VAR13,1)) AND CLOSE/VAR12<1.23;
VAR15:=REF(CLOSE,1)/REF(CLOSE,3)<1.15 AND REF(CLOSE,1)/REF(CLOSE,2)<1.08 AND REF(CLOSE,3)/REF(CLOSE,4)<1.09 AND REF(CLOSE,4)/REF(CLOSE,5)<1.09;
VAR16:=FILTER(VAR11,21) AND CLOSE>VAR12 AND CLOSE/REF(CLOSE,1)>=1.09 AND VAR15 AND CLOSE/VAR12<1.23;
VAR17:=REF(CLOSE,2)/REF(CLOSE,3)>1.09 AND CLOSE>VAR7 AND REF(CLOSE,2)>VAR7 AND CLOSE/REF(CLOSE,2)<1.02 AND CLOSE/REF(CLOSE,1)>=1.09;
VAR18:=CLOSE<LLV(CLOSE,14)*1.22 AND CLOSE/REF(CLOSE,1)>1.09 AND VAR15 AND CLOSE>VAR7 AND CLOSE/VAR12<1.23;
VAR19:=(VAR17 OR VAR16)*0.56;
VAR20:=FILTER(VAR14,9) AND VAR15;
天天涨停:=VAR19 OR VAR20 AND BARSCOUNT(C)>30;
STICKLINE(天天涨停,18,22,2,0),COLORAAAAAA;
{DRAWTEXT(CURRBARSCOUNT=25,20,'★天天涨停★ '),COLORAAAAAA;}
DRAWTEXT(VAR19 OR VAR20 AND BARSCOUNT(C)>30,20,'★天天涨停★ '),COLORAAAAAA;
{疯牛启动}
A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线王:=EMA(A2,200)*1.118;
条件:=(C-REF(C,1))/REF(C,1)*100>8;
疯牛启动:=CROSS(C,金线王) AND 条件;
STICKLINE(疯牛启动,12,16,2,0),COLORFF8800;
{DRAWTEXT(CURRBARSCOUNT=25,14,'★疯牛启动★'),COLORFF8800;}
DRAWTEXT(CROSS(C,金线王) AND 条件,14,'★疯牛启动★'),COLORFF8800;
{涨停捉妖正版}
XA_1:=EMA(EMA(EMA(HIGH,13),13),13);
XA_3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_4:=XA_3>9.5 AND HIGH<XA_1*1.25;
涨停捉妖正版:=FILTER(XA_4,5)COLORRED;
STICKLINE(涨停捉妖正版,6,10,2,0),COLOR0022CC;
{DRAWTEXT(CURRBARSCOUNT=25,8,'★涨停捉妖正版★'),COLOR0022CC;}
DRAWTEXT(FILTER(XA_4,5),8,'★涨停捉妖正版★'),COLOR0022CC;
{初级战法}
SG:=EMA(HHV(H,1),8);
X1:=EMA(C,8);
X30:=X1<REF(X1,1) AND C<X1;
X31:=IF(((SG<REF(SG,1)) OR X30),1,0);
当天涨停:=((COUNT((X31=1),4)=3 AND X31=0 AND C/REF(C,1)>1.095));
初级战法:=当天涨停>=1;
STICKLINE(初级战法,0,4,2,0),COLORBROWN;
{DRAWTEXT(CURRBARSCOUNT=25,2,'★初级战法★'),COLORBROWN;}
DRAWTEXT(当天涨停>=1,2,'★初级战法★'),COLORBROWN;

通达信疯牛起爆涨停捉妖指标公式

相关文章