在线检测未来函数

通达信神龙解量指标公式

来源:Internet,编辑:股旁网,2022-05-02

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1006”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
Vvol:IF((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VOL*(TOTAL+3)/(CTIME+3),DRAWNULL),NODRAW;
stICKLINE((CURRBARSCOUNT=1 AND DYNAINFO(8)>1),VVOL,0,-1,-1),COLOR00C0C0;
DX_1:=ma(VOL,35);
DX_6:=IF(OPEN>CLOSE,OPEN,CLOSE);
黑心柱:=VOL>2*DX_1 AND (CLOSE<OPEN OR (HIGH-DX_6>0.5*(HIGH-LOW) AND (HIGH-LOW)/REF(CLOSE,1)>0.05)),COLORFF6633;
VAR1:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
成交:=VOL,COLORCD52FF,LINETHICK0;
主动买盘:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLOR0000FF,STICK;
主动卖盘:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00E521,STICK;
买卖比:=主动买盘/主动卖盘,COLORYELLOW;
买比:=主动买盘/V;
卖比:=主动卖盘/V;
WJ:=(HIGH+LOW+CLOSE)/3;
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
VD6:=(VD1*VD5);
VD7:=(VD2*VD5);
VD8:=(VD3*VD5);
VD9:=(VD4*VD5);
买入量:=(VD9+VD8);
卖出量:=(VD6+VD7);
买入资金:=买入量*CLOSE/100;
卖出资金:=卖出量*CLOSE/100;
资金进出:=买入资金-卖出资金;
资金买卖:=买入资金+卖出资金;
买卖资金比:=买入资金/卖出资金;
买资金比:=买入资金/资金买卖;
卖资金比:=卖出资金/资金买卖;
挂单买盘:=MA(主动买盘,3);
挂单卖盘:=(MA(主动卖盘,3));
TIMELT:=IF(DATE>=1230326,0,1);
STICKLINE((主动买盘 > 0) AND TIMELT,0,主动买盘,2.86,0),COLOR6058FF;
STICKLINE((主动卖盘 > 0) AND TIMELT,0,主动卖盘,2.86,0),COLORFFFF00;
{量能生命线}
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
量柱:=BLZ,COLORYELLOW;
DRAWICON(倍量柱,VOL*1.18,18),COLORYELLOW;{倍量}
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
生命线:=FILTER(HJZ3,5),STICK,COLORRED;{黄金柱}{生命线}
DRAWICON(生命线,VOL*1.06,23),COLORRED;{生命线}
{新VOL}
DVAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(DVAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(DVAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (DVAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (DVAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
量比:=(VOL / MA(VOL,5));
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);
鬼比:=(卖盘 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
上攻均量:=MA(买盘,JY1);
下攻均量:=MA(卖盘,JY1);
换手率:=((VOL / CAPITAL) * 100);
DRAWICON((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (换手率 > 1)),(VOL * 1.01),25)*TIMELT,COLOR00FFFF;{量变}
DRAWICON((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (换手率 > 1)),(VOL * 1.1),24)*TIMELT,COLOR00FFFF;{量变}
T6:=(VAR8>VAR6) AND (VAR8>VAR7) AND 买盘>0,COLORWHITE;
T61:=(VAR8>VAR6) AND (VAR8>VAR7) AND 买盘>0,COLORWHITE;
T7:=(VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE > OPEN) AND 买盘>0,COLORYELLOW;
T71:=((VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE > OPEN) AND 买盘>0),COLORYELLOW;
T8:=((VAR7 > VAR6) AND (VAR7 > VAR8) AND 买盘>0),COLORMAGENTA;
T81:=((VAR7 > VAR6) AND (VAR7 > VAR8) AND 买盘>0),COLORMAGENTA;
T9:=((VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE < OPEN) AND 买盘>0),COLORFF6633,COLORCYAN;
T91:=((VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE < OPEN) AND 买盘>0),COLORFF6633,COLORCYAN;
T10:=((VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE < OPEN) AND 买卖差<0),COLORGREEN;
T101:=((VAR6 >= VAR7) AND (VAR6 >= VAR8) AND (CLOSE < OPEN) AND 买卖差<0),COLORFF6633,COLORGREEN;
T11:=(黑心柱),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T6 AND TIMELT,0.6,0,0,'★机会风险提示:【洗盘庄家找底振荡,轻度洗盘,伺机建仓'),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T7 AND TIMELT,0.6,0,0,'★机会风险提示:【建仓】主力吸筹进货并且成交量出现黄金柱,跟随进货等起航'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T8 AND TIMELT,0.6,0,0,'★机会风险提示:【高抛】主力高抛低吸低吸高抛')COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T9 AND TIMELT,0.6,0,0,'★机会风险提示:【减仓】主力低位深度洗盘或高位出货坚决'),COLORFF6633;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T10 AND TIMELT,0.6,0.16,0,'★机会风险提示:【清仓趋势破,庄家撤退'),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND T11 AND TIMELT,0.6,0.33,0,'★★★机会风险提示:【主力黑心,请控制风险】'),COLORYELLOW;
主力启动线:MA(VOL,5),COLORRED,LINETHICK1;
主力洗盘线:MA(VOL,35),LINETHICK1,COLORYELLOW;
资金异动线:MA(VOL,135),LINETHICK1,COLORMAGENTA;
DRAWICON(crOSS(主力启动线,主力洗盘线) AND V>主力洗盘线 AND V>资金异动线 AND 主力洗盘线<资金异动线,V,10);
{UNDEFINED高低距------------------------}
DRAwrECTREL(460,1000,0,0,RGB(10,0,0)),COLORBLUE;{UNDEFINED活动框};
{柱图}
SATTOL:=(V/C)/(HHV(V,1)/HHV(C,1));
买卖量:=IF(SATTOL>1,1,SATTOL),COLORLIBLUE,NODRAW;
SATBU:=(主动买盘/C)/(HHV(主动买盘,1)/HHV(C,1));
主动买盘量:=IF(SATBU>1,1,SATBU*买比),COLORLIBLUE,NODRAW;
SATSEL:=(主动卖盘/C)/(HHV(主动卖盘,1)/HHV(C,1));
主动卖盘量:=IF(SATSEL>1,1,SATSEL*卖比),COLORLIBLUE,NODRAW;
SATGDBU:=(挂单买盘/C)/(HHV(挂单买盘,1)/HHV(C,1));
挂单买盘量:=IF(SATGDBU>1,1,SATGDBU*买比),COLORLIBLUE,NODRAW;
SATGDSEL:=(挂单卖盘/C)/(HHV(挂单卖盘,1)/HHV(C,1));
挂单卖盘量:=IF(SATGDSEL>1,1,SATGDSEL*卖比),COLORLIBLUE,NODRAW;
SATZJBU:=(买入资金/C)/(HHV(买入资金,1)/HHV(C,1));
买入资金量:=IF(SATZJBU>1,1,SATZJBU*买资金比),COLORLIBLUE,NODRAW;
SATZJSEL:=(卖出资金/C)/(HHV(卖出资金,1)/HHV(C,1));
卖出资金量:=IF(SATZJSEL>1,1,SATZJSEL*卖资金比),COLORLIBLUE,NODRAW;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和度:=(IF(SAT>1,1,SAT)),COLORRED,NODRAW;
图长度像素:=80*0.5*TIMELT;
当日买卖量图:=(买卖量)*图长度像素+230*0.8;
当日主动买量图:=(主动买盘量)*图长度像素+230*0.8;
当日主动卖量图:=(主动卖盘量)*图长度像素+230*0.8;
当日挂单买盘图:=(挂单买盘量)*图长度像素+230*0.8;
当日挂单卖盘图:=(挂单卖盘量)*图长度像素+230*0.8;
买入资金图:=(买入资金量)*图长度像素+230*1.86;
卖出资金图:=(卖出资金量)*图长度像素+230*1.86;
量能饱和度图:=(量能饱和度)*图长度像素+230*1.86;
DRAWRECTREL(120,90,CONST(当日买卖量图),25,RGB(255,0,255)*TIMELT);
DRAWRECTREL(120,230,CONST(当日主动买量图),165,RGB(255,0,0)*TIMELT);
DRAWRECTREL(120,365,CONST(当日主动卖量图),305,RGB(0,255,0)*TIMELT);
DRAWRECTREL(120,665,CONST(当日挂单买盘图),605,RGB(255,0,0)*TIMELT);
DRAWRECTREL(120,825,CONST(当日挂单卖盘图),760,RGB(0,255,0)*TIMELT);
DRAWRECTREL(370,230,CONST(买入资金图),170,RGB(255,0,0)*TIMELT);
DRAWRECTREL(370,365,CONST(卖出资金图),310,RGB(0,255,0)*TIMELT);
DRAWRECTREL(460,76,370,0,RGB(150,10,250));
DRAWRECTREL(460,76,370+CONST(量能饱和度*(460-370)),0,RGB(0,100,0));
DRAWTEXT_FIX(1,0.0,0.0,0,STRCAT(STRCAT('当日买卖量(手):',CON2STR(VOL,0)),' ')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.0,0.15,0,STRCAT(STRCAT('当日买量:',CON2STR(主动买盘,0)),' ')),COLORRED;
DRAWTEXT_FIX(1,0.0,0.3,0,STRCAT(STRCAT('当日卖量:',CON2STR(主动卖盘,0)),' ')),COLORGREEN;
DRAWTEXT_FIX(1,0.0,0.45,0,STRCAT(STRCAT('当日买卖比:',CON2STR(买卖比,2)),' ')),COLORYELLOW;
DRAWTEXT_FIX(1,0.0,0.6,0,STRCAT(STRCAT('当日挂单买盘:',CON2STR(挂单买盘,0)),' ')),COLORRED;
DRAWTEXT_FIX(1,0.0,0.75,0,STRCAT(STRCAT('当日挂单卖盘:',CON2STR(挂单卖盘,0)),' ')),COLORGREEN;
DRAWTEXT_FIX(1,0.2360,0.15,0,STRCAT(STRCAT('买入资金累计万元: ',CON2STR(买入资金,0)),' ')),COLORRED;
DRAWTEXT_FIX(1,0.2360,0.3,0,STRCAT(STRCAT('卖出资金累计万元: ',CON2STR(卖出资金,0)),' ')),COLORGREEN;
DRAWTEXT_FIX(1,0.236,0.45,0,STRCAT(STRCAT('资金进出万元: ',CON2STR(资金进出,0)),' ')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.236,0.6,0,STRCAT(STRCAT('买卖资金比: ',CON2STR(买卖资金比,2)),' ')),COLORYELLOW;
DRAWTEXT_FIX(1,0.236,0,0,STRCAT(STRCAT('量能饱和度: ',CON2STR(量能饱和度,2)),'%')),COLORYELLOW;

通达信神龙解量指标公式

相关文章