在线检测未来函数

大智慧短线看盘主图指标公式

来源:Internet,编辑:股旁网,2010-11-27

{DRAWGBKLAST(DATE>900101,STRIP(RGB(15,125,5),RGB(0,5,0),0));}
DRAWTEXTABS(5,08,BKNAME+' '),COLORCYAN;
牛熊线: EMA(CLOSE,30),CIRCLEDOT;
M1:EMA(C,3),COLOR00ff00,LINETHICK2;
M2:EMA(M1,2),COLOR00ff00;
M3:EMA(M2,2),COLOR00ff00;
M4:EMA(M3,2),COLOR00ff00;
M5:EMA(M4,2),COLOR00ff00;
M6:EMA(M5,2),COLOR00ff00;
PARTLINE(M1,M1>M2),COLOR00ffff,LINETHICK1;
PARTLINE(M2,M2<M1),COLOR0022ff,LINETHICK1;
PARTLINE(M3,M3<M1),COLOR0022ff,LINETHICK1;
PARTLINE(M4,M4<M1),COLOR0022ff,LINETHICK1;
PARTLINE(M5,M5<M1),COLOR0022ff,LINETHICK1;
PARTLINE(M6,M6<M1),COLOR00ffff,LINETHICK1;
三日涨幅:=(CLOSE-ref(CLOSE,3))/ref(CLOSE,3)*100;
五日涨幅:=(CLOSE-ref(CLOSE,5))/ref(CLOSE,5)*100;
七日涨幅:=(CLOSE-ref(CLOSE,7))/ref(CLOSE,7)*100;
十日涨幅:=(CLOSE-ref(CLOSE,10))/ref(CLOSE,10)*100;
十三日涨幅:=(CLOSE-ref(CLOSE,13))/ref(CLOSE,13)*100;
十五日涨幅:=(CLOSE-ref(CLOSE,15))/ref(CLOSE,15)*100;
二十日涨幅:=(CLOSE-ref(CLOSE,20))/ref(CLOSE,20)*100;
三十日涨幅:=(CLOSE-ref(CLOSE,30))/ref(CLOSE,30)*100;
看跌:= LOW<M2 AND CLOSE<M1 AND (M1-M2)<0.04;
卖出:=filter(看跌,4);
转势:=cross(M1,M3) and M6>M5 and c>M6;
买入:=filter(转势,1);
drawicon((买入),l*0.97,7),ALIGN1;
drawicon((卖出),h*1.02,8),ALIGN1;
PARTLINE(牛熊线,牛熊线>REF(牛熊线,1)),CIRCLEDOT,COLOR0000ff;
DRAWTEXTABS(5 ,40 ,'流通盘:'+capital/1000000+'亿'),COLOR00FF00,linethick1;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
每股公积金:=FINANCE2(7);
每股未分配:=FINANCE2(8);
{股旁网-股票公式网站 www.gupanG.com}
DRAWTEXTABS(125 ,40,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),Color00FF00;
DRAWTEXTABS(240 ,40,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),Color00FF00;
DRAWTEXTABS(360 ,40,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORYELLOW;
DRAWTEXTABS(5,55,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,Color00FF00;
DRAWTEXTABS(125,55,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,Color00FF00;
DRAWTEXTABS(285,55,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,Color00FF00;
DRAWTEXTABS(5 ,70,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),Color00FF00;
DRAWTEXTABS(125 ,70,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),COLORYELLOW;
DRAWTEXTABS(5 ,85,'三日涨幅:'+NUMTOSTRN(三日涨幅,2)+'%'),COLORRED;
DRAWTEXTABS(125 ,85,'五日涨幅:'+NUMTOSTRN(五日涨幅,2)+'%'),COLORRED;
DRAWTEXTABS(245 ,85,'七日涨幅:'+NUMTOSTRN(七日涨幅,2)+'%'),COLORRED;
DRAWTEXTABS(5,100,'十日涨幅:'+NUMTOSTRN(十日涨幅,2)+'%'),COLORF00FF0;
DRAWTEXTABS(125,100,'十三日涨幅:'+NUMTOSTRN(十三日涨幅,2)+'%'),COLORF00FF0;
DRAWTEXTABS(245,100,'十五日涨幅:'+NUMTOSTRN(十五日涨幅,2)+'%'),COLORF00FF0;
DRAWTEXTABS(5,115,'二十日涨幅:'+NUMTOSTRN(二十日涨幅,2)+'%'),COLORF00FF0;
DRAWTEXTABS(125,115,'三十日涨幅:'+NUMTOSTRN(三十日涨幅,2)+'%'),COLORF00FF0;
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个红武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
解盘:='【K线形态解盘】'+
IFs(倾盆大雨,'★倾盆大雨;','')+
IFs(大阴烛,'★大阴烛;','')+
IFs(好友反攻,'★好友反攻;','')+
IFs(跳空缺口,'★跳空缺口;','')+
IFs(光脚阴线,'★光脚阴线;','')+
IFs(光头阳线,'★光头阳线;','')+
IFs(三只乌鸦,'★三只乌鸦;','')+
IFs(分离,'★分离;','')+
IFs(长下影,'★长下影;','')+
IFs(长上影,'★长上影;','')+
IFs(下跌三部曲,'★下跌三部曲;','')+
IFs(上升三部曲,'★上升三部曲;','')+
IFs(早晨之星,'★早晨之星;','')+
IFs(黄昏之星,'★黄昏之星;','')+
IFs(十字星,'★十字星;','')+
IFs(长十字,'★长十字;','')+
IFs(垂死十字,'★垂死十字;','')+
IFs(早晨十字星,'★早晨十字星;','')+
IFs(黄昏十字星,'★黄昏十字星;','')+
IFs(射击之星,'★射击之星;','')+
IFs(倒转锤头,'★倒转锤头;','')+
IFs(锤头,'★锤头;','')+
IFs(吊颈,'★吊颈;','')+
IFs(平顶,'★平顶;','')+
IFs(穿头破脚,'★穿头破脚;','')+
IFs(乌云盖顶,'★乌云盖顶;','')+
IFs(曙光初现,'★曙光初现;','')+
IFs(身怀六甲,'★身怀六甲;','')+
IFs(十字胎,'★十字胎;','')+
IFs(平底,'★平底;','')+
IFs(大阳烛,'★大阳烛;','')+
IFs(三个红武士,'★三个红武士;','')+
IFs(双飞乌鸦,'★双飞乌鸦;','')+
IFs(孕育线,'★孕育线;','')+
IFs(多方炮,'★多方炮;','')+
IFs(出水芙蓉,'★出水芙蓉;','');
DRAWTEXTABS(5,25,解盘),LINETHICK1,COLORff00FF;
DRAWFLAGTEXT(倾盆大雨,c,'★倾盆大雨,见顶信号'),COLORFF00FF;
DRAWFLAGTEXT(大阴烛,c,'★大阴烛,后市向淡,发生逆转'),COLORFF00FF;
DRAWFLAGTEXT(好友反攻,c,'★好友反攻,底部反转'),COLORFF00FF;
DRAWFLAGTEXT(跳空缺口,c,'★跳空缺口,注意向上还是向下跳空'),COLORFF00FF;
DRAWFLAGTEXT(光脚阴线,c,'★光脚阴线,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(光头阳线,c,'★光头阳线,后市看涨'),COLORFF00FF;
DRAWFLAGTEXT(三只乌鸦,c,'★三只乌鸦,可能见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(分离,c,'★分离,注意看涨分离和看跌分离'),COLORFF00FF;
DRAWFLAGTEXT(长下影,c,'★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留 意'),COLORFF00FF;
DRAWFLAGTEXT(长上影,c,'★长上影,表明行情上档压力沉重,升势受阻'),COLORFF00FF;
DRAWFLAGTEXT(下跌三部曲,c,'★下跌三部曲,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(上升三部曲,c,'★上升三部曲,上涨信号'),COLORFF00FF;
DRAWFLAGTEXT(早晨之星,c,'★早晨之星,见底回升'),COLORFF00FF;
DRAWFLAGTEXT(黄昏之星,c,'★黄昏之星,见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(十字星,c,'★十字星,有转向意味,注意股价位置在顶部还是底部'),COLORFF00FF;
DRAWFLAGTEXT(长十字,c,'★长十字,注意在顶部还是底部'),COLORFF00FF;
DRAWFLAGTEXT(垂死十字,c,'★垂死十字,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(早晨十字星,c,'★早晨十字星,上涨信号,见底回升'),COLORFF00FF;
DRAWFLAGTEXT(黄昏十字星,c,'★黄昏十字星,下跌信号,见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(射击之星,c,'★射击之星,可能见顶回落,可靠性低'),COLORFF00FF;
DRAWFLAGTEXT(倒转锤头,c,'★倒转锤头,可能见底回升'),COLORFF00FF;
DRAWFLAGTEXT(锤头,c,'★锤头,可能见底回升,如有量配合,信号强烈'),COLORFF00FF;
DRAWFLAGTEXT(吊颈,c,'★吊颈,上升行情中见顶回落,顶部出现,见顶信号'),COLORFF00FF;
DRAWFLAGTEXT(平顶,c,'★平顶,温和的反转'),COLORFF00FF;
DRAWFLAGTEXT(穿头破脚,c,'★穿头破脚,顶部出现,见顶回落信号'),COLORFF00FF;
DRAWFLAGTEXT(乌云盖顶,c,'★乌云盖顶,见顶回落信号'),COLORFF00FF;
DRAWFLAGTEXT(曙光初现,c,'★曙光初现,后市见底回升'),COLORFF00FF;
DRAWFLAGTEXT(身怀六甲,c,'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信 号'),COLORFF00FF;
DRAWFLAGTEXT(十字胎,c,'★十字胎'),COLORFF00FF;
DRAWFLAGTEXT(平底,c,'★平底,温和的反转'),COLORFF00FF;
DRAWFLAGTEXT(大阳烛,c,'★大阳烛,看涨'),COLORFF00FF;
DRAWFLAGTEXT(三个红武士,c,'★三个红武士,每日收盘价上移,表示可能见底回升'),COLORFF00FF;
DRAWFLAGTEXT(双飞乌鸦,c,'★双飞乌鸦,行情将见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(孕育线,c,'★孕育线,注意股价位置'),COLORFF00FF;
DRAWFLAGTEXT(多方炮,c,'★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复 合见顶信号'),COLORFF00FF;
BM:=ZIG(3,5)*100;
GM:=MA(BM,2);
DM:=CROSS(BM,GM);
WM:=CROSS(GM,BM);
EM:=REF(INDEXC,1);
DRAWTEXT(FILTER(DM=1,5),LOW-1.2,'↖买'),LINETHICK2,ALIGN1,COLOR00FFFF;
DRAWTEXT(WM=1,HIGH*1.03,'逃'),LINETHICK2,ALIGN1,COLOR33FF33;

大智慧短线看盘主图指标公式

 

相关文章