在线检测未来函数

大智慧均线解盘主图指标公式

来源:Internet,编辑:股旁网,2013-11-01

if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
ee:=hhv(h,ddd);
MSTATUS:=BARSTATUS=2;
MA5:MA(C,5),PRECIS2;
MA10:MA(C,10),PRECIS2;
MA30:MA(C,30),PRECIS2;
MA60:MA(C,60),PRECIS2,LINETHICK1;
MA125:MA(C,125),ColorFFFF00,PRECIS2,LINETHICK1;
MA250:MA(C,250),PRECIS2,LINETHICK1;
i:=1;
IF MSTATUS and (MA5 > MA10 and MA10 > MA30 and MA5 > MA30) THEN BEGIN DRAWTEXTABS(0,i*16,'短期均线多头排列。股价高位谨防筑顶。中低位当股价向上突破5、10、30日均线,均线呈多头排列是最佳买入时机;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 < MA10 and MA10 < MA30 and MA5 < MA30) THEN BEGIN DRAWTEXTABS(0,i*16,'短期均线空头排列。股价高位谨防弃庄,卖盘涌出破位下跌。中低位当股价向下突破5、10、30日均线,均线呈空头排列时,注意观察股价所处箱体位置;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > MA60 and MA30 > MA125 and MA60 > MA125) THEN BEGIN DRAWTEXTABS(0,i*16,'中期均线多头排列。注意股价突然下跌,当股价回档至当前盘面30、60、125日任一均线获得支撑,关注均线助涨,次日股价放量向上突破,是中长期最佳买入时机;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 < MA60 and MA30 < MA125 and MA60 < MA125) THEN BEGIN DRAWTEXTABS(0,i*16,'中期均线空头列排。30、60、125日中长期均线下行呈空头排列,注意箱体上下撑压或无量空跌;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA60 > MA125 and MA125 > MA250 and MA60 > MA250) THEN BEGIN DRAWTEXTABS(0,i*16,'长期均线多头排列。即60,125,250日均线向上多头排列。注意:当股价处于箱体顶部,所有均线多头排列,股价反复震荡不能突破,可能顶部即将形成;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1; END;
IF MSTATUS and (MA60 < MA125 and MA125 < MA250 and MA60 < MA250) THEN BEGIN DRAWTEXTABS(0,i*16,'长期均线空头排列。即60,125,250日均线向下空头排列。注意:当所有均线空头排列的时候,股价处于箱体的一个次高位,中位,或箱体下沿,可能是阶段底部的形成;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA5,MA10)) THEN BEGIN DRAWTEXTABS(0,i*16,'短期5日10日均线金叉。30日和其他均线是否成为股价上涨的阻力,或股价在高位的运行方向,判断是反转上涨还是下跌中途的小反弹;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA10,MA5)) THEN BEGIN DRAWTEXTABS(0,i*16,'短期5日10日均线死叉。当股价反弹遭遇30日和其他均线的阻力形成死叉,可能是股价下跌中途的小反弹。高位区死叉,必须逃顶止损;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA125)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价上穿半年线。在半年线上方运行的个股被称为强势股。适合中小资金根据短线技术指标套利操作;'),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA125,C)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价跌破半年线。在半年线下方运行的个股被称为弱势股。适合大资金进场吸筹操作;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价上穿年线。股票筑底后,股价经过反复震荡洗盘上穿年线,予以锁定跟踪;'),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(MA250,C)) THEN BEGIN DRAWTEXTABS(0,i*16,'今日股价跌破年线。跌破年线,证明深度调整格局可能形成。如果后市股价继续深跌,调整时间和空间难以预测;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (CROSS(C,MA60) and CROSS(C,MA125) and CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,'股价一阳穿三线。5、10、30日均线三线合一,股价一阳穿三线,向上反转,可能变盘反转在即;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势向上。注意:如果股价在低位中位30日均线之上,围绕另一条重要均线缩量横盘,随后5-10日均线金叉,所有均线向上呈多头排列,是中长期绩优牛股的摇篮;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 > REF(MA30,1) AND MA30 < REF(MA30,1)*1.001) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势走平。需观察5日和10日均线方向,如30日均线发出趋势向下信号,5日10日均线形成死叉,注意减仓或出货;'),COLORFFCC66,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA30 < REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均线趋势向下。关注股价所处箱体位置,如股价当前上涨或下跌时,则需观察箱体阻力支撑位置。如果股价处于远离30日均线位置,一般情况下股价反弹空间有限;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 > REF(MA5,1)*1.015) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线强劲向上。需观察股价所处其他均线和箱体位置,如果收盘时股价突然跌破5日均线,则需观察箱体下方支撑,提防空头陷阱,股价转向;'),COLORRED,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 > REF(MA5,1) AND MA5 < REF(MA5,1)*1.005) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线方向不明。当股价连续跌破5日均线和箱体下沿,导致股价方向开始向下,股价在箱体内则需观察股价下方的重要均线位置,可否获得支撑;'),COLORYELLOW,ALIGN0,LINETHICK1;
i:=i+1;
END;
IF MSTATUS and (MA5 < REF(MA5,1)*0.985) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均线快速向下,短线风险可能降临。如果股价在一个大箱体中,则需观察下方均线支撑,偌收盘前股价获得支撑,5-10均线金叉并数日向上,则可顺势而为做多;'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i+1;
END;

大智慧均线解盘主图指标公式

 

相关文章